Black/white vector: fill without dithering (line-fill?)

I’m trying to engrave a stamp, this involves burning lots of rubber away. My source is an SVG that is black and white, and I just need to burn away all the black.

In general, when I’m burning a line the laser is used far more heavily (I assume it is never turned off for movement). But when when selecting fill it goes back to dithering (shoot a point, turn off laser, move, repeat), lowering the material removal rate significantly.

Since for this case I don’t need dithering at all, is there a way to have lightburn just use a no-laser-off ‘line’ pattern as the fill? This would probably save me a lot of time.

If I understand, you may have an image / raster bitmap embedded in that SVG file. This would have LightBurn place the image on an Image Mode layer. If you want to scan fill the shapes, you will need to trace or convert these shapes to vectors first, but this assumes I understood you. :wink:

Show us what you see, and we can offer a bit better feedback.

vector-rastering-example.lbrn2 (87.1 KB)
Hey Rick, thanks for taking a look.

Attached is a sample project with a stamp (the forum doesn’t allow upload of SVG images).
What I observe is: when the filled in parts (C16, fill setting) are traversed, the temperature of the laser is very low and flare-ups are small. This indicates to me that on average max power isn’t used. (laser dot, off, move, repeat?)
When doing the continuous lines (C05) the laser diode temperature shoots up (and the fan kicks on) and the burn flare is significantly higher, indicating a lot more power is used. (both are at 100% power, although speeds are different)

I can try and splice the power line for the laser and confirm this measurement.

Edit: there is no embedded bitmap in the SVG, I just doublechecked

I’ve had another go at this, but no success getting the laser power metered in a meaningful way. But what I see is the line-part works very well and very quickly, creating lots of particulates. The fill part is comparatively very tame and thus slow to reach results (distance burned away).

I’m really under the impression that the “fill” in a vector import is slower than a “line”, even tough both should go at full blast if I’m not mistaken? There is no “pass-through” in a vector.

On my next attempt I’m (uneducatedly trying things) going to see what happens if I convert the image to a raster format and see what pass-through gives there.

(I realise there is a decent chance my expectations are wrong and not the software, but I would really like to understand this)

This sounds like GRBL with laser mode turned off ($32=0). Should be $32=1.

That’s just a guess though, without knowing what controller you are using.

Thanks for your ideas! It’s a cheap Neje lasermaster 2S max, so that may be part of the problem. $32 is set to 1 (fresh start of the machine and newly opened lightburn).
Is a vector source considered to be functionally equal to a raster one?