Bloqueo codigo G ( G code lock )

hola buenos dias he adquirido un laser jinsoku lc-40 y no me deja hacer nada me sale una advertencia de bloqueado.
Corriente de inicio

Hello, good morning. I have purchased a jinsoku lc-40 laser and it won’t let me do anything. I get a blocked warning.
start current


El objetivo de movimiento del código G excede el recorrido de la máquina. Posición de la máquina retenida de forma segura. Puede desbloquear la alarma. (Haga clic derecho en el botón ‘Dispositivos’ para restablecer la conexión)

The G code movement target exceeds the machine travel. Machine position safely held. You can unlock the alarm. (Right click on the ‘Devices’ button to reset the connection)

En o cerca de la línea 2:

On or near line 2:

Secuencia completada en 0:00

Sequence completed in 0:00

[MSG:Reset to continue]


Grbl 1.1f [‘$’ for help]

[MSG:‘$H’|‘$X’ to unlock]

[MSG:Caution: Unlocked]


This is a soft limit error, make sre you are in absolute cordenates

If that does not work, try this information.

1 Like

I see that you have communication from the Console in LightBurn so you’ve overcome the first challenges.

Is this a behavior that happens as soon as LightBurn connects?

For the error to be this early, out of hundreds or thousands of lines, I’m wondering where you’ve chosen your origin and if the engraver is attempting to go ‘Home’

Please Zoom-out to capture the whole LightBurn work area, and the Laser Window, and capture the screen. You can drag the image into this reply box or upload it with the Upload feature in the reply box.
2023-07-02_01-23-02 upload icon in reply window

To determine the intended homing behavior of your engraver we should review the Machine Settings. With your engraver connected and communicating as you have done please type the following into the Console window in LightBurn:
and press enter.

Please scroll back in the Console window, Select and copy the text and paste this report into a reply here.

Please click Edit, then Device Settings and capture this screen for review as well.





































These show that the engraver is Set to be capable of Homing.

Autohome on Startup is selected, (The Lower arrow) which is what I was hoping to see.

Please turn off Relative Moves for Z. ( the upper arrow ) The Working space for Z is configured as if it allowed 1mm of travel. This may interfere with homing.

You will want these numbers to be 375 and 385 as shown.
2023-07-03_05-54-55 working space settings

This might home correctly after these changes.
Please test and let us know. :slight_smile:

teclas desactivadas y medidas corregidas.

keys disabled and measures corrected.

estoy harto del programa este que no hay solucion,lo del Gcode me tiene loco ya ya no se que hacer,bueno si que lo se voy a cerrar todo y a devolver la maquina.

I’m fed up with this program that there is no solution, the Gcode thing has me crazy, I don’t know what to do anymore, well, I do know, I’m going to close everything and return the machine.


Código G bloqueado durante el estado de alarma o desplazamiento.

En o cerca de la línea 0:

G code locked during alarm or displacement status.

On or near line 0:


Código G bloqueado durante el estado de alarma o desplazamiento.

En o cerca de la línea 0:

Secuencia completada en 0:00


Código G bloqueado durante el estado de alarma o desplazamiento.


Código G bloqueado durante el estado de alarma o desplazamiento.

I google it and:
Error 9 can be offered by your laser engraver, through the LightBurn Console window for several reasons. A common reason for new users is caused by requesting the laser go home when switches haven’t been installed to support the request

Do you have limit switches installed?
If yes, can you be more specific when and how the error occurs?

Lo googleo y:
Su grabador láser puede ofrecer el error 9 a través de la ventana LightBurn Console por varios motivos. Una razón común para los nuevos usuarios es solicitar que el láser se vaya a casa cuando no se han instalado interruptores para respaldar la solicitud.

¿Tienes interruptores de límite instalados?
En caso afirmativo, ¿puede ser más específico cuándo y cómo se produce el error?

Often there is an Error or an Alarm before Error 9.

Please repeat this, scroll back and show us any other messages you may have received.

This appears to be related to your previous post. I will append this thread it to that thread and we can continue from there.

The user manual leaves quite a bit to be desired, but the X Limit switch and cable are mentioned in the User Manual.

The Laser window shows which coordinate system you are using. It would be wise to use Absolute Coordinates until we resolve this technical challenge.

2023-07-05 Laser window forum 103991 (spanish)

When LightBurn starts and connects with your engraver, there is a behavior called Homing that the machine is expected to do. The Laser Engraver moves toward two switches, one for each axis and touches them and then backs away 2.000mm ($27) from the switch.

In the Console window in LightBurn, enter the following command to Home the laser:
and press Enter.

Please confirm for us that the engraver moves toward two switches and touches them and then backs away from them 2mm.

new device settings forum 103991 (crop)

You turned off Autohoming on Startup… This should be turned on as you had it set - if the switches are present. You have not told us this.

If the switches are not connected we make different adjustments.

If homing completes with an error, Please Select and Copy from the Console window from $H to the word ‘ok’ and paste it into a reply here.

If homing proceeds away from the switches, this will generate an error. This will be more difficult. If this happens let us know.

If homing completes with no error, then we test the Jog arrows (Shown Below) to confirm that the Origin is in the correct corner, (Usually near the switches) and that LightBurn sends the Move commands correctly.

In the Move window, set the numbers on the right in the boxes to these numbers. Also confirm that these are in mm/minute (not mm/second) as shown. This is very important and can generate the error you saw.

Test all Four compass arrows on the left and confirm that the laser goes Left-Right (X-Axis) and Toward you and Away from you (Y-Axis).

Please let us know that these are ok.

Finally, Please capture the Cuts / Layers window and post it in a reply here. High Speeds can create excessive Overscan which can go out of bounds. We should look here:

Cuts -Layers settings forum 103991 (crop)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.