Boss Laser HP-5598 help finding device

I tried running the find my laser part of LightBurn and it doesn’t find it. it almost seems as though it doesn’t really look. i have downloaded the drivers that came with lightburn, though i can’t seem to find them in the device managers.

i know my computer is seeing the machine because when i plug the cable in it makes the ding noise.

the laser is turned on and nothing is queued to run.

i have looked everywhere but can’t seem to find any information that helps me to connect my machine to the software.

Try setting it up manually as a Trocen device.

I picked Ruida Device manually but not sure what else needs to be done to make it see the laser. i also entered the bed size and such.

I was mistaken on the controller, the HP series from Boss is a Trocen controller. Try that.

I tried that but when i try to send the file it says failed. machine is either paused or busy. it is neither of those. and all files have been cleared from the machine. I really appreciate your quick help. is there anything else i should try?

The HP-5598 specifies LaserCAD as the included software so it should be a Trocen AWC controller in there.

  • Can you show us pictures of your machine and controller? What I care about in particular is the exact model # specified at the top of the controller display. AWC608/ 708, lite?
  • Have you ever installed or used the LaserCAD Software that presumably came with the machine?
  • How are you connected to the laser - USB, Network…? Details please.

AWC708C Plus
Yes i used Laser Cad in the past (it works but the software is terrible).
I have tried both USB and Ethernet Cable.


So here is how I fixed the problem.

Reinstalled LaserCad, including the driver.

Plugged the USB directly into the bottom of the AWC708C Plus Controller.

Went into LightBurn and right clicked on the device button to refresh the connection.

Also to be clear the device was set up manually using the Trocen AWC, and USB connection.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.