Boss Rotary Not Rotating the Correct Circumference

I have a Boss LS 2440 with RUIDA 644xs. Lightburn 1.0.04 installed. Using Boss rotary attachment. I have not run any cups/bottles in a while but having a problem with rotating the bottle based on its diameter. I have never had any problem in the past, so I am a little surprised. I use the rotary setup feature and use the parameters I have used before. When I run the test using the rotary setup the bottle only rotates about ½ the circumference of the bottle.
What settings should I be using for the stock Boss Rotary? Is there something other than what I enter in the rotary setup tool that would cause this problem? Is there an order to setting up the rotary settings?

Circumference on bottle in 9 inches diameter set to 2.125
Roller Diameter I’m using is 2.5 inches
Revolutions set to 6800

I’ve never used a boss rotary, but on mine (PiBurn) I just set the diameter of the driving wheels and the number of steps for a complete rotation. Everything else gets figured out for me.

Seems to me the ratio of the drive motor to wheel is 2.5 to 1. A single rotation (based on the stepper motor driver board settings) is 2000 steps/revolution. 2000 x 2.5 = 5000 in steps/rotation
And the drive wheel is 62mm. That is all I have entered.

Screenshot from 2021-10-17 15-53-58


1 Like

Seems no matter what adjustment I enter nothing changes. I do not get any error when making changes.

Set Roller using Radius of wheel an it works OK.

The circumference of a circle is Pi x Diameter.

All of this starts with steps/rotation of the motor, then to the gear ratio of the rotating device, ending up with the diameter of the driving wheel.

Since it works with Diameter / 2, I would think you have the gear ratio or the steps/rotation being 2 times what they should be.

I think it would be more difficult get the end product off by exactly 2 times with a combination of both being incorrect, so it’s probably one or the other.

Give us the values you used to compute these numbers.

steps/rotation - these are on your motor driver
gear ratio - device manufacturer
driving wheel diameter - device manufacturer


sorry Jack but… what version of LB you have?
i’ve got the last 1.0.04 and my rotary setup is not like yours

Here are my settings.
Question on rotary setup, Once you have setup your parameters when you test the object on the rollers should it make one complete revolution? I have made several changes an never get a complete revolution.

LightBurn 1.0.04, built Sat 2021-10-02 @ 13:40

All of these show the same information. Yours is labeled different.

I’m thinking that ‘mm/rotation’ is really ‘steps/rotation’. Can you try that?

I think it’s a translation difference. It would be a headache for the software otherwise.

Would probably help us help you.


no i don’t think so, maybe setup will change based upon the type of board and rotary you connect?
i see you have the button “read settings” that is not present in my setup.
Can someone @LightBurn_Staff tell me if i’m wrong? i’m only curious.
BTW my machine is a selfmade with MKS DLC V1.2 corexy with Neje A40630 laser module.

I think there is a misunderstanding.

Do you plug your rotary into the Y axis?

Did you try the values that @rwebcon supplied for his Boss?

The numbers you show are way off from what I’d expect.

You controller isn’t connected.

We have asked for information from you. No one can probably answer many of these kind of technical question without information.


I will place a call to Boss an ask them for clarification on rotary setup. I have tried many different settings an none give to a complete revolution when I use the test button. Next I will try an contact LightBurn for some input.

It’s most likely a configuration issue. No one can help you if you refuse to answer their questions.

Relax and we’ll get this sorted.

There is no difference in the setup gui that I can see. Maybe if you pointed it out to me that would help.


Naturally i’m quite new to laser but i use 3D printers for a long time so i’m not a total noob with connections, btw…

  1. the controller is connected and powered
  2. i use Z axis not Y
  3. my rotary is a selfmade so i think that values for Boss rotary will not work with mine

this is the image from the machine equipped


and i don’t know what more info you need

Guess I confused this with you have a Boss rotary attachment

I don’ think you’re following me. I see the numbers in the gui, did you get them from a fortune cookie?

Where did you get 360 mm/revolution?

Don’t you question where you have 360, I have 5000 and @rwebcon has 6800?

I doubt that your stepper has 360 steps/rotation.



if you see last image, the first you are looking at was done before setup, i have 32mm to complete a revolution NOT step… millimeters.
In any case my rotary works as expected so… i think that the different GUI is because i have a self made rotary, and it works like a charm.

I guess I missed what the solution was…

Glad you’re up.

Take care, enjoy :slight_smile:


There were no issue, only a question about dufferences in the Rotary GUI setup

Should have done this earlier. From the Lightburn documentation, "For a chuck rotary, this will be one rotation of the chuck, and for a roller, it will be
one full rotation of the roller, NOT the item. " So I was expecting on rotation of the cup/bottle, wrong it the wheel!

If it were one rotation of the item, you would have to change the values for every different item you put on the rotary… :frowning:

Glad you’re up that’s the main thing. Take care and enjoy it…


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.