Brand new user with Formbot T-Rex 3D printer

I just downloaded Lightburn to try because Dragonfly 1.7 that came with my Formbot T-Rex 3D printer is worthless.
I plugged in my 3D printer and had the program look for any compatible lasers but nothing. So now I need to know what to do. Normally, I would place the gcode on an SD card and insert that into the machine. Hit run from SD card and the laser does its thing.
Where do I find information on how to my particular 3D printer with lightburn?
I am assuming that I would go into creat manually, select one of the GRBL models, but which one?

A quick Google search shows that 3d printer uses the very popular Marlin firmware.

You might find what your looking for here:

Thanks for the response. I tried Marlin and it controls everything but the laser on and off. I was able to home (how ever my machine homes to the center of the build platform and that is not an option) after some trial and error. When I run the gcode it looks as if it is doing what the preview shows but the laser never turned on.
I am doing a search for that but if you have a link I would appreciate it.

How is your laser connected? (IE, to which fan port?) Depending on your build, you might need M3 / M5 commands, or M106 / M107, and/or a different tool index. Both of those can be set in Edit > Device Settings near the lower right of the window.

Thank you for the reply.
I just found the M3 M5 by looking at the old file from Dragonfly and changed in the settings. Now the laser turns on and fires at the correct times, I am assuming because it is not burning anything into the wood. I am trying to increase the distance from the wood, manual focusing, increasing the power, etc.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.