Bridge is now faltering?

Thank you all–I feel like I only ask questions around here, but I’m learning a ton and I appreciate the thoughtful responses

I have the latest Lightburn software running on a Mac talking to my Boss Laser LS 1420. It’s connected via the Lightburn Bridge Kit, which as worked flawlessly, bridging my wifi network to the Bridge via an ethernet cable to the Boss.

In the last few weeks, only sometimes the following will happen:

I’ll hit FRAME and the laser will burst into action, framing the part to be cut.

Then I’ll hit SEND and I’ll see this:

There was a problem sending data to the laser.

But if I hit it a few more times, sometimes it’ll work.

Or then, if I go to EDIT and hit MACHINE SETTINGS, I’ll see this:

But sometimes, I’ll see this:

And while this refresh often causes it to then allow SEND, it might be a coincidence.

So if I go to RE-SCAN in the ‘laser’ subpanel, I’ll see this

And again, that sometimes works, and sometimes doesn’t.

So I have this erratic problem. FRAME almost always works the first time, but sometimes need two tries. SEND, just in the last few weeks, often doesn’t work the first time, but sometimes does.

All my jobs are very simple.

I’ve unplugged the Bridge twice and let it sit to see if it was in need of a reset.

It’s all so weird.

Any thoughts on how to troubleshoot?

Thank you.

I have a close setup to yours with the Lightburn Pi Bridge. I think the problem is really the Ruida, not the software in between. I’ve worked with this type of communication system for a couple of decades and it’s very dependable.

The Ruida works with UDP packets and the bridge helps dealing with issues that arrive.

Fail to send and the Machine Settings failing to load is not that uncommon and has always indicated to me the Ruida wasn’t listening or in some other mode. It’s Ethernet does leave a lot to be desired.

Ensure you have a good wifi signal to the Pi.

Next time you have an issue like this, try to press ‘esc’ on the Ruida and it should respond. This gets it ‘out’ of many of the modes. As it seems to ignore the Ethernet when it’s doing something else.

Good luck


thanks Jack

I’m on it.

will report back

I hit ESC and it worked

then I did another cut and hit ESC and it didn’t work

so I hit ESC again and it didn’t work

but the third time, it did

so perhaps I’m just a dancing monkey, but we’ll continue to watch and press.


Trying again a week later… still no luck

asked for controller info:

Total ‘on’ time (HH:MM:SS): 25:19:00

Total job processing time (HH:MM:SS): 10:49:36

Previous job processing time (HH:MM:SS.msec): 0:00:00. 0

Total 'job ‘laser on’ time (HH:MM:SS): 8:35:40

Total job count: 171

X Total travel (M): 2013

Y Total travel (M): 575

Mainboard firmware version: RDLC-V8.01.67

not sure what else to try?

suggestions are welcome. Thanks.

I have had problems with my bridge when it stays powered on. A quick reboot of the bridge usually helps along with the ESC button.