Bug after Purchase or maybe Update?

I think I have a bug, but it just showed up. I’ve been using the trial for the last month and purchased the full version today. I also just installed the last update today. To see the error, look at the picture. See the image shift on the top row numbers “30”, the 5’s on “15” and “25” and the 2 on the “32” in the bottom row. I ran this 3 times on three different materials and it had all the same exact misalignments. Help would be appreciated.

If you send just the “30” to the laser, does it do this? And if so, does it also look wrong on the LCD display? If it looks wrong in the output, but not the display, it’s likely that the steppers slipped while running that part of the file, possibly because you ran it too quickly. What speed were you using for the text?

Seems unlikely to be slipping since it did the exact same thing on three different burns. The speed on that text is only 200, my machine can go up to 500. It doesn’t look like there is any “slipping” on any of the ampersands on the bottom line. Those all ran at 200 also.

I’m pretty new at this, but I don’t think I could send just the “30” to the laser. All the text (except the amersands) are one layer. I could just send that one layer.

Yes, that is one way, but that will, as you identify, send everything on that layer. To just send something of your choosing, select said something, then tick the ‘Cut Selected Graphics’ ON (green) to send only what is selected to the laser.

So you’re saying if I drive around a corner too fast, and lose control, that it’s unlikely to happen the same way again?

Yes, in a straight line. Not a chance in the world you’re hitting that 200 mm/sec on small text, and I see slippage on all of these spots:

image

Rick, that line of text (the top line of numbers) is all one text box. From what I can tell, I can still only select the entire text box. I’m not missing anything, correct?

Oz & Rick… Also, it seems to be off when it moves to a new area. Watching the simulation preview, the 0 in “30” on the top row is burned by burning the center “0” first, then it moves over the the “3” in the “35” and then it goes back to the exterior of the “0” on “30”. Most of the slippages seem to be in this sort of situation.

Is 200 an unusual speed to burn at? Are there options for other settings to deal with this?

My optimization settings that I selected were:
Untitled

Forgive me if I am confused. I just don’t really understand, since I pretty recently burned at speeds 350 and 500 and didn’t have noticeable slippage. I’m wondering if something got corrupted on this file or if something in my formatting could be improved. Or something else. Just trying to understand.

Here are the settings for that layer:


I really appreciate your help!

Was this engraving, where the motion is very simple, back & forth, or was it cutting small shapes with lots of right angles and loops? Those are very different cases.

Not likely - 200 mm/sec for vector marking of small shapes is quite fast, and depending on where you bought your laser, the manufacturer may have set the acceleration settings “optimistically” - I see it often.

Motion control systems can’t really account for resonance - Your laser has mass, and the gantry and belts have flex, even if it’s very small. When the laser changes direction rapidly, things will flex a little. If it changes direction again very quickly, that flex can “slingshot” the system in the other direction, causing a slip, and it may take a few of these ‘slingshot’ motions to build up enough momentum to make the motors lose position. This is resonance.

To see how little movement it takes to cause resonance, watch this video, around the 1:30 mark, and again at about 2 mins:

This exact thing can happen with the laser head if it changes direction fast enough a few times in a row.

I stabilized the table I have my laser engraver on and that resolved about 30% of the issue. Then I leveled the engraving bed itself and tightened the timing belt just a smidge. That seems to have resolved it completely. Thanks for your help!