Bug: Arrays Windows 11

Windows 11
i3, 4GB RAM, SDD

When I do a grid for waste board, and I delete the layers leaving blank, but arrays still left, I need to restart the program.

I do a waste board 10mm and repeat it.

Can you detail out exact steps to reproduce? I’ll try to replicate the issue.

Start a waste board, put horizontal and vertical two layers. 10mm lines and duplicates (arrays) to fill the board. So do you want to horizontal and the other one verticals. delete the layers. See that repeats.

Note sure if I’m following your example but here’s the setup prior to deleting the layers.

Then with all layers gone:

Not getting any hangup in LightBurn.

Is this the correct setup?

I’m on W11 but running a beta version but don’t recall ever seeing an issue like this.

I turned off the grid.

I did either two horizontal and vertical lines or one does the same thing.

The following post may help. In it, I offer a few ways to create exactly what you are after. Please review and let us know if you encounter any snags along the way. :slight_smile:

(preview looks odd but is valid)

What happens after you delete the layer? What makes you have to restart the program?

I delete the layer, the grid doesn’t disappear. I removed the OEM grid and still there… I saved the document, and open it again and grid is gone.


I think I’m fundamentally misunderstanding the stated problem.

Are you saying that when you save a document with the grid that you created that it’s not there when you reopen the file? Or are you somehow attempting to replace the workspace grid with your own?

I think I’m missing exactly what you’re attempting.

  1. Create grid by array.
  2. Delete the layer. But you see the grid with array still.
    Do you see it ? The grid still ?

No need saving. I saved it because I had to reopen the project with more stuff besides grid.

Sorry it’s hard for me to explain, had a brain tumor.

Yeah, the first picture you sent me that it was correct so looks like it’s not happening on your computer.

Maybe my computer is weak, what is the minimum for the software.

Sorry about the brain tumor but I think I understand it now.

You’re saying that even after deleting the shapes created by the Array tool that they still appear on screen?

If so, that’s very unusual.

Are you certain it’s not the LightBurn workspace grid that’s showing? Do you have any problem deleting any other shapes in LightBurn?

I’m almost certain it’s not the speed of your computer that’s the issue here. I ran LightBurn on a very low power Raspberry Pi 3 and it worked pretty much the same as on my laptop.


Got it now.

I can reproduce the issue based on the video and agree that this is likely a bug.

This applies to any virtual array.

Steps to reproduce.

  1. Create a virtual array
  2. Delete the entire layer on which the virtual array is created directly in Cut / Layers window

The virtual portion of the array will remain.

@Rick @Lightburn for visibility.

Thank you. I missed that bit. Investigating further now…

@infowire, Thank you for the video, it provides exactly what we need to see. Difficult to describe with words, you did fine. The video clearly shows what appears to be the line not being removed from the workspace display when using the ‘Layer Trash’ icon in the Cuts / Layers window. The shape being produced via Virtual Array allowed me to find right away.

Thank you both for bringing this to our attention and helping to run it down. :slight_smile:

Update: I am able to reproduce and will generate a report.

1 Like

Awesome I did something useful :grin:


We have a resolution to this and put it into the latest Public Beta available now. While not required, feel free to test it for yourself.

We are rapidly moving from beta to release candidate, shipping the 1.4.00 Official Release very soon-ish, so you have the option to wait for that event as well. Thanks again for reporting this. :slight_smile:

1 Like

Works for me in latest Beta. :clap:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.