Bug: extra cutting path when automatic tabs are turned on


I’ve encountered a possible bug, that happens when Tab Generation is turned on (tabs per shape = 3)
the problem goes away when i turn off this feature.

it causes an extra cutting path to be generated it seems, one that doesn’t show up in in the right click preview.
i thought at first perhaps the laser was getting stuck on, while it traveled to its next location, leaving a scar accross the parts im cutting, but after watching it several times, this doesn’t appear to be the case.
the laser seems to be moving to a location other than its intended cut path, or travel path.


  • Do you have lead-in / lead-out or overcut enabled?
  • Do you have ‘Remove overlapping lines’ enabled in the optimizations?

I don’t know of any specific issue, but it’s possible there could be interaction between these and tabs. The ‘Remove overlapping lines’ in particular caused an issue with overcut at one point, so that’s a possibility.

I havn’t done much exploring into this issue, but heres the settings i was using at the time when it was working just fine.

121184545_681855269134211_3120691920226449950_n 121600214_829430487911874_2772750004605869965_n

here, when i turned on automatic tab generation, is when the problem began.

You do have a small overcut enabled (0.2mm) - Try setting that to zero to see if that fixes it. If it does, that would be a good clue for us. This is for a C3D / GCode machine, correct?

I’ve done a bit more testing, first i reduced the number of passes to make it quicker, and a smaller different shape.
same results as before with different shapes, a single shape, or multiple shapes to cut.
number of passes does not affect the behavior.

turning off the overcut you mentioned (while tabs are on) does seem to resolve the issue

changing the tab size, and overcut size, has no effect.

tabs alone is fine
overcut alone is fine
both turned on gives the problem behavior.

it seems the extra move it does, is going towards one of the tabs that are generated.
these pics show the laser heading for the tab.
(tab size, and overcut greatly overexaggerated for testing)
extra cut is circled in red


Is there a reason you need overcut when you’re adding tabs? The point of overcut is to go a little past the end when cutting a closed shape so you’re sure the start/end point is cut all the way through. Adding tabs forces some spots to be skipped, intentionally not cutting all the way through, so they serve opposite purposes.

It shouldn’t do what it’s doing, and we’ll fix it, but the simplest fix will be to make it ignore the overcut setting if you have tabs enabled (or force it off) because they don’t quite make sense together.

Nope, there’s no reason for me to have both turned on, I originally had overcut turned on, for its intended purpose, later on I decided to give tabs a try, as I had pieces falling out, and getting wrecked by the laser. so it was more a matter of, I forgot it overcut was turned on when i tried out tabs.

Just checking - Adam has made the change to the cut prep code to shut off overcut and lead in/out if tabs are enabled. I’ll be making the UI shut off those fields for entry if tabs are enabled.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.