Bug: importing to art library breaks the library

I downloaded a number of SVG files from the internet and added them to a new art library via the import function in lightburn. When I view the library in LB I have an “off by one” error part way through the list. In other words, the name displayed in the library view and the actual name (as shown at the bottom of the icon pane) do not match.

You can see this in the screen grab here:
image

Exiting LB and reloading doesn’t fix the problem.

I’ve tried unloading the library, existing LB, deleting the actual .lbart file on disk, and importing again. Same problem occurs (sometimes in a different place in the library).

All the graphics are CC0 so I don’t mind emailing the lbart file to you, but I don’t want to upload it in the forum. I can also email the original graphics I downloaded / imported if that’s helpful.

I’m using 1.6.03 but I haven’t tried this in other versions.

Yes please and thank you for bringing this to our attention. Please email support@lightburnsoftware.com with these files and as much detail as possible, include a link to this post for context, and include “bug” in the title of the message to assist in the routing. We can follow up there. :slight_smile:

Email is on it’s way. It’s a total of about 10M. I hope your email can handle that. If not, let me know and I’ll resend with links to download the attachments rather than actually attaching them to the email.

Please confirm that you’ve received the email.

I received a confirmation email so I assume you got it.

1 Like

Just checked, we received your email. Thank you. :slight_smile: