Bug issue on latest release of 9.25

I have noticed a bug that is driving me crazy. If i import an image, lets say of an eye, then change the settings i want on it, such as power, speed, dither, etc. If i use the array copy tool to make 5 copies of it, it changes the settings to super random settings, including turning on overscan to 30%, changing speed to 82,000, changing power to some random number as well as changing the dither type. it is super frustrating because no wi have to go back and change each one.

thanks

What version of LightBurn on which OS? You say 9.25 release, which is not publicly available at this point. It’s only available to our beta group for testing at this point. Please double-check, ‘Help’→’Quick Help and Notes’→’About’ tab for version number.

Please show us how this happens for you. What steps you take to reproduce the behavior you are observing. I am not seeing the same. The Grid / Array tool produces exact copies for me. All copies are placed on the same Layer as the original and thus inherit the settings from that layer.

Are you saying that each copy produced when you use the Array has different settings for the copy? Are they all produced on the same Layer? Please show us examples of what behavior you are observing.

1 Like

i am on version 0.9,25 on windows 10 build19041. Yes i have the pre-release because version 0.9.24 would nto save processed BMP’s. Lightburn kept deleteing them. i had a ticket via the support email on this very issue. I was instructed to test 0.9.25 and that fixed the issue along with uninstalling avast virus scanner

If i take the single image, adjust properties, then make a array of it in the x direction, settings stay ok, but if i select ONE of the images, and put it on its own layer, it randomly chooses settings. Each time i put an image on its own layer, the settings change randomly. In the attached photos, you will see how one of the speeds is 60,000.

the first image is after the array, youll see how the settings are still the same for each one, but as soon as i assign each image to its own layer, lightburn changes everything on me. this makes it difficult to accomplish my goal

thanks


it has also turned on power scale under shape properties, which it never was, and also turned on overscanning, changes my dither type from stucki to dither, and changed my scan angel as well as seen in this image. ypou can see the original settings with 90 as scan angle, 1200 speed, etc vs the randomly changed settings
turns on overscanning and other options

Thank you for clarifying the version you are using as one of our recent test releases.

Changing which layer the image is placed on is making these changes, yes. They are not random. This is expected and the way LightBurn works. :slight_smile:

You define the cut settings for a given layer, then place things that you want cut with those settings on that layer. Use a single layer if you want all images to use the same cut settings. You also have separate control over each individual image from the ‘Shape Properties’ tab.

If you want to quickly copy one layers settings to another, look to the right side of the ‘Cut / Layers’ window. Hover over buttons for Tool Tips.

-

You have additional options for controlling each layer.

If you find a Layer setting you prefer for a given material, you can save it to a ‘Material Library’ for quick recall when using that material again. Material Library - LightBurn Software Documentation

2 Likes

ok, im still trying to understand why its a feature though? I mean, when i put one of the images on its own layer, options i never ever used or had turned on in the first place were turned on. IE, speed of 60,000?? overscan of 10%, power scaling, dither, and scan angle. I can understand the layer resetting back to a default or something but not sure i understand why lightburn decided to pick 60,000 as a acceptable speed haha

i will practice some more with the tools you told me about and see if i can get the settings from one layer to copy over to another:)

Also, concerning the power scaling tab, how does that work? IE, if i put 40% in for the power scaling, des that mean the power for that specific image is set to 40%? or is it 40% OFF 100 meaning the power is really 60?

thanks

Power Scale: Scales the power used to cut this shape by this\npercentage between Min Power and Max Power - Shape Properties - LightBurn Software Documentation

1 Like

interesting. Ok, i see why you guys have done what you have done. Im not to that point yet, but hopefully in the near future, ill be making some more complicated stuff, but i only have the ortur lm2 20 watt laser so i can only do so much haha.

ill have to mess around with the power scale feature. I thought it was the actual percentage the laser would use, IE, i set it to 55%, means the laser would burn at 55%. im trying to make a speed/power test file without having a million layers. hence why i was asking about power scaling :slight_smile:

thanks.

You can build your own test files, but one of our creative members produced this to help as well: Lightburn PowerScale Generators - O2 Creative

1 Like

yeah i tried this test out but it didnt work very well. it gave me really odd power settings. when i looked in lightburn the 50% power was around 37%, this is why i am making my own, it will be actual correct numbers for my diode laser:)

Layers here have slightly different meanings than in graphics editors. Layers are used to group items like in graphics editors however, each layer has an implied laser control/operation/setting. When doing more complicated design I may have one layer that is used to slightly etch the top of the material to a certain depth. Then another layer that will etch deeper and then I have more one more layer that I use to cut out the piece I am working on from the stock.

So in this example I have 3 layers. The etching layers use faster speed and lower power since I just want to modify the face of the material. The cutting layer will use lower speed and higher power since it needs to remove a lot of material.

So when you copy shape from one layer to another, you may the “shape” but the laser settings do not copy.

1 Like