Bugs with the Control Windows (Not all of them)

Hello

I have started using Lightburn and I have discovered a bug (or I’m manipulating the windows incorrectly)!!!

If I “undock” a control such as “move”, I get a separate window with the move controls. If I want to return it to the dock on the right of the screen, I can move it back over one of the other controls and it docks and I have a selection for the control at the bottom of the dock. This is I assume the correct way to work. Unfortunately, this behavior does not work for the “console”, the “library”, and the “laser” windows. These undock perfectly well, however, if I want to dock them again, they do not want to and remain as floating windows only.

I am using version 1.6.00 on an Apple MacBook Pro running Sonoma 14.5

Thanks

Jim

Did you try double-clicking each window bar?

Hi @parsec

Yes, tried that, and it works on some of the windows, but not on the console, the laser, or the library

You are right. Tested now and didn´t work.
But double-click double-click works. :slightly_smiling_face: or click double-click ( it´s like that windows need to get focus from system )???
That’s odd.

Hello again @parsec

I’ve made a little movie to show the problem, but the explanation is as follows:

1: Right-click on the screen and select window.
2: Choose a window
3: Click the second icon at the top right to undock the window
4: Press the red x of the undocked window to close it
5: Try docking again and it will not dock

Note that if you do not undock and then close the window, then this does not happen. The docking process appears to work fine

If you can’t recreate this, let me know how I can get the movie file to you

Thanks

Jim

I was able to replicate this behavior with Laser window and unable to dock again with 1.7.00 nor even at the left side.
Lets call the eyes of @adammhaile or @JoeSpanier for the 1.7.00.

Thanks @parsec

I’m glad you were able to replicate this and it was not totally user error… :wink:

Jim

Luckily I have 4 Lightburn instances running. So closed that one, on another changed working size setting, click ok then changed back the same setting “just to force” Lightburn saving current defaults, and everything ok as before without resetting.
From now on always gona keep 2 or more instances running as a trick “to revert”.

I’ve just restarted LB, and it resolves the issue

1 Like

Hold shift while launching LB and it will force reset the window to default state with everything docked back where it is “from the factory”.
Unable to repro this locally, but I’ll keep an eye out for it.

3 Likes