Burn points at the beginning and of each letters ore design

Hi there, as you can see one the picture, I have burning point at start and end of ingraving. Can I solve this in the software ? Power was 15% and speed 1850.

1850 what? KPH? mm/ss? This will be important to clarify, but the corner burns are from the laser controller not adjusting the power when slowing for direction change. What firmware are you using to drive your Eleks and what are the settings? My guess is you do not have set correctly so post and we can review.

I have posted this before but provide here to help as well:

Check your setting for $30 and $32 in the console by typing $$ and pressing enter.

$32 should be 1 (enable laser mode)

$30 should be 1000

The $30 value can be set either in your firmware to match LightBurn, or in the LightBurn device settings (S Max) to match your GRBL setting.

Here is another great resource for your setup.


As another member previously posted, “Scroll down to the bottom “operating instructions” and follow that. Once you have it working in elekscam, it should work in lightburn. Follow the instructions to the letter and that will get you up and running…”

You would need to be using GRBL 1.1f to be able to use the Laser Mode ($32) setting that Rick references above. That is called ‘dynamic power’ mode, and varies the power output of the laser as the speed changes, so when it slows for corners, it doesn’t burn them.

Ok , here are some pictures of my settings as well as a test
! 20200428_161646|123x500

are some pictures of my settings as well as a test

still have burning points

Can you save some GCode for a simple test, and paste the top few lines of the gcode text file here?

Hi Oz,
You mean during a burning test i guess…
This afternoon asap after work :wink:

There it is

Those are not the top few lines, but part of the middle instead, which doesn’t tell me what I need to know.

Here are some different tests whit different settings, and all with the same outcome. Deeper points and lines at the beginning and the end of the lines. For filling ore outlining

You’re using GRBL-M3 as the device in LightBurn, which uses constant power (the M3 command) instead of variable power (the M4 command). That’s why you have burn dots on your line starts.

Okay, this is New for me, is there a solution , some modifications to make , software adjustments, something to download??
Ore is it so and can’t be fixt??

You would need to upgrade your firmware to GRBL 1.1f or later so you can use the variable power mode, which adjusts the power output based on the speed. It reduces this kind of artifact to almost nothing. And you would switch to the ‘GRBL’ device in LightBurn instead of GRBL-M3.

Grbl 1.1f is already installed, so basically I have to change the machine choice as GRBL instead of grbl M3 … correct ?
Sorry for the stupid questions :slight_smile:

Correct - GRBL-M3 uses the M3 command to turn on the laser, which is Constant Power mode. The ‘GRBL’ driver uses the M4 command for Variable Power mode.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.