Burning Atomstack X7 Pro


I can’t found the solution to the problem I have. My Atomstack X7 Pro is working with LaserGRBL but not with Lightburn. The laser is not recongnized automatically by the program, so I used the manual option and choose the GBRL. Homing is ok, he is starting with lasering. But the output is very vague.

Any help is really appriciated.


I have the same problem.
Have you found a solution yet?

Can you provide more detail about this? In what way is it vague?

Can you issue a $$ command in console and paste here the result?

Also, what is the value of S value Max in Device Settings?


After a lot of testing, I made progress. Finally, I use the default GRBL driver and I finally found the Cuts / Layers part to change the laserpower. After some playing around, I found the right value.

But may be new Atomstack has more features that I did not turn on yet? No idea, still need to found out the difference between M3 / M4 etc.

But first I need to but a license :wink:


M4 allows for variable power so that let’s say you’re going around a bend and that slows down the laser head in order to make the turn, power will be reduced as to not overburn that area. You can override this on a per cut layer basis by using “Constant Power” setting.

There is a specific device type GRBL-M3 I think that’s meant for older GRBL versions that didn’t have laser mode.

1 Like

I have similar issue.
had the a5pro, upgraded to the x7.
Lightburn thinks the x7 is an a5.
Having Lightburn search for the laser finds nothing.
a5 is 8 bit if I remember correct and the x7 is 32bit apparently, also with double lasers. not sure if that changes parameters.
when I first got it I ran the dog cut test from the hand controller. 3rd cut it blasted right through the 5mm ply. I ran my own file and with 4 cuts could not get through.
I have also noticed it likes to home every time it is done. and doing so it lost its calibration to the x axis (my y cut was offset).

I have not tried it in GRBL as I dont use GRBL.

In what way does LightBurn think that the x7 is an a5?

This seems to contradict the previous statement. Please explain.

It doesn’t matter to LightBurn whether or not the boards are 8-bit or 32-bit. The double laser likewise doesn’t matter.

Sounds like these were different designs. How did you ensure that power ratings and speed were the same?

Do you mean it does a full homing cycle after each job is finished? If so, this isn’t being triggered by LightBurn. Or does it move the laser head to the 0,0 position without homing and hitting the endstops? If the latter then that’s normal. You should not lose steps in that scenario, only if the endstops were involved.

Please explain the situation for this. LightBurn doesn’t home between passes, or layers of a job. Were you doing 2 layers manually on the same material and homing between layers?

I dont know how to respond with fancy quotes…

I mentioned i was using a a5 prior. When i plugged in the x7… It connects to the same driver. Down in the bottom right where you select the device. Eventhough the x7 is connected it shows the a5 connected ( and is not).
So to hopefully fix this i click on find my laser device. And it comes up blank.

8bit. Ok

Yes different files but still cuts. Found that both plywoods were 5mm but two different batches. Seems that this batxh is super hard. Re ran the dog on same sheet. With handheld x6 cut 100% only the tight spots started to burn through.
I dont know what speed the handheld or grbl runs at.
My bad

Homing… I just set endpoint to the other side. No more shifts.
Will fiddle with this again.
Honestly bad choice in the switch by atomatack.

If you select a portion of text an option will appear to quote the text.

Sounds like they use the same driver and are on the same COM port more likely. Just edit your device and change the name to what you’d like. Make sure the work area is correct for the x7 and that the machine origin is correct (Device Settings). If your machine homes to the front left then this should be the bottom left dot for Origin in Device Settings.

I’m not sure if I’m following this. You physically move the endstops to a different location? Did you change the homing direction configuration to match this? If not, I’m not sure you’ve done what you think you’ve done.

From the looks of the A5 Pro and X7 it seems the A5 Pro is meant to home to the upper left while the X7 is meant to home to the lower left. Also, does the A5 Pro have limit switches? I didn’t think it did from factory.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.