Burning image issue

Trying to burn image and I keep getting error that says error code around line 9 or 10 and also something about a letter in the g code

Without more information, this discussion may be helpful (it’s for a diode laser, but the error seems about the same)l:

Your Genmitsu is probably a GRBL machine, so make sure that’s what LightBurn thinks it is.

If that doesn’t solve the problem, copy-n-paste the Console log to provide more detail on what’s going on.

here is the log Im new at this so let me know if I missed something
Thank You

Grbl 1.1f [‘$’ for help]
Grbl for GD32
Version:GD32 V2.1
$0=10 (step pulse,usec)
$1=0 (step idle delay,msec)
$2=0 (stepport invert mask)
$3=4 (dirport invert mask)
$4=0 (stepenable invert,bool)
$5=1 (lims pin invert,bool)
$6=1 (probe pin invert,bool)
$10=0 (status report mask)
$11=0.001 (junction deviation)
$12=0.002 (arc tolerance,mm)
$13=0 (report inches,bool)
$20=1 (soft limits,bool)
$21=1 (hard limits,bool)
$22=1 (home cycle,bool)
$23=3 (homing dir invert mask)
$24=100.000 (homing feed,mm/min)
$25=500.000 (homing seek,mm/min)
$26=250 (homing debounce,msec)
$27=1.000 (homing pull-off,mm)
$30=1000 (maximum spindle speed,rpm)
$31=0 (minimum spindle speed,rpm)
$32=1 (laser mode enable,bool)
$100=800.000 (X axis pulse:step/mm)
$101=800.000 (Y axis pulse:step/mm)
$102=800.000 (Z axis pulse:step/mm)
$103=177.777 (A axis pulse:step/mm)
$110=2000.000 (X axis max rata:mm/min)
$111=2000.000 (Y axis max rata:mm/min)
$112=2000.000 (Z axis max rata:mm/min)
$113=1000.000 (A axis max rata:mm/min)
$120=20.000 (X axis acceleration:mm/s^2)
$121=20.000 (Y axis acceleration:mm/s^2)
$122=20.000 (Z axis acceleration:mm/s^2)
$123=20.000 (A axis acceleration:mm/s^2)
$130=400.000 (X aixs max travel:mm)
$131=400.000 (Y aixs max travel:mm)
$132=80.000 (Z aixs max travel:mm)
$133=9999.000 (A aixs max travel:mm)

This section of the doc explains some things you’ll see:

With more details:

Make sure you have plain old GRBL selected as the device type:

The other GRBL options apply to weirder GRBL ancestors and descendants than (I think) your machine has.

Then start with the simplest possible Device Settings:

With all that checked out, things should work better.

That’s how all of us started: welcome aboard!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.