Busy or Not Connected

Need help. I tried LIghtburn on my Mac and thought it was just the Mac - I couldn’t get it to work, SO I tried my son’s Windows-based machine and had the same problem. Keep thinking it must then be a cable problem so I changed out cables - same. I have attached pictures. If anyone can help, I would appreciate it. I am using the new Ikier K1 Pro Max 70 W. I Have tried LaserGRBL, and I can get that software to work with this laser and the same cables - so that makes me think it’s, not the cables.

Is com3 your only option?
Are you running thru a USB hub?

Considering Com3 was shown before and USB 2.0 connection I would imagine:

  • either there are other com port
  • Machine is not being identified at all

Yes Comm 3 is only option and no on the hub. direct to computer.

Only com ports are the 1 USB and 1 USB-C
Using a Surface Pro 7 now but same situation on MacBook.

I think you are right that it’s not recognizing the machine. As I mentioned, the lasrer is the new Ikier 35/70 W. Wondering if Ikier has the bug in it?

Try this if you can
Unplug your laser
Right click windows start menu
Click Device Manager

Expand the ports section. Is there any port there?

Now power up your laser, and plug the USB
Does any port come up?
Try the USBc side of the cable
(by the way i am assuming you are using a non stock cable?)

Could you take Not connected and connected pictures of your device manager and post here?

Going back and forth betwen 2 computers.

I am using the cable that came with machine - plus have tried several other cables.

There is no Port showing until I plug the USB -C then
USB-Serial CH40 (COM 3) pops up.

Right click this device → Uninstall
Then unplug and plug USB cable again
Windows will auto detect again the machine should give it again com3 or a different port

Also in lightburn, did you add your machine manually or use Find my laser?

Before I go back to laser., I had to add manually because it could not find my printer.

1 Like

It came back with USB Serial and nothing else - no Comm3 or anything

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.