Button "Move x+" sends the command G1

Hi there!
When I move the laser head with the “Move X +” button, the command G1 is generated. This will activate the laser on my Smoothieboard. Normally, however, the command G0 should be transmitted when moving with “Move X +” so that the laser is not activated. What solution is there for this problem or can you change it in Lightburn?



Hello Wolfgang,
in laser mode Smoothie S parameter is the laser power setting and without it each move will fire the laser. Try sending from Lightburn’s console something like G1 X10 S0 and see what goes. if this works for you Oz should add that to the smoothie driver.

I tried it. Unfortunately it doesn’t work that way. The PWM output is also activated when I start G1 X10 S0. The PWM output remains off only with G0! This is also what the Smoothieware documentary says. I just noticed something else. When running a program with fill, G1 … S0.2 is output at the end of each command line, but not when running along a line!

Just checked. lightburn includes the S0 parameter and my laser is not firing when moving the laser head using the UI. I can however invoke a G1 move and see the laser fires first thing after resetting the board and then sending a G1 commad from console before touching the move arrows in the UI. this will move and fire at the same time and when i add S0 - it moves without firing and will stay in that state until board is reset.

ok, this line is sent when I work with the arrow buttons: “G1 X10 Y0 F12000 S0”
Tomorrow I’ll take a look at the signal with the oscilloscope, but the line “G0 X10 Y0 F12000” would actually be the correct version! When processing a job, G0 is also used between the elements! So why not with the move X buttons?
Can you tell me why when cutting a element as a job at the end of the G1 no S values are given? If I choose fill then the S-value is correctly output!

Fair enough. You might have a point there and G0 should be used instead. never bothered with this as I don’t use the console to move around nor the moving arrows.

OK! Why in a job when cutting no S-value output but when filling?

The S value is only output when it changes, so if you rewind to the start of that, you’ll see one, but it’s not necessary otherwise.

Regarding jogging moves, we output them using G1 so we can specify the movement speed without affecting the G0 default rapid rate. You likely have the “minimum pwm” setting in your Smoothieware config set too high - it’s firing the laser when the S parameter is set to 0, and it should only fire when S is higher than zero.

Problem solved! If “minimum pwm” is set to 0.0, there is no PWM output.
Thank you and have a nice New Year!

If you’re using a CO2 laser you probably want to set that value to just below the firing threshold of the laser, so it still cuts properly when you do squares or things with sharp corners - play with the setting to find the sweet spot.

1 Like

Ok, I’ll experiment with that!
So you should only control the CO2 laser via this PWM? Should you then leave fire constantly activated and control the power from 0 to 100% via the PWM or is it better to set the power of the laser with a potentiometer to the maximum value you want and then go on fire with PWM?

I’m sorry, but I don’t understand what you mean by “leave fire constantly activated” - which “fire” do you mean? LightBurn uses G0 to move between cuts, but G1 to move when engraving so the speed is consistent, which can improve the engraving output.

The SKR V1.3 is connected to the small adapter board for the ribbon cable. Today I wanted to do the first test. Now it’s about the connection of the SKR with the laser PSU. In the meantime I have read a lot about how the board should be connected to the PSU in many forums and also here.
To be on the safe side, I also looked up the Smoothiewaredoku again and found that:

In order to control the power of the laser tube, the laser PSU reads a PWM signal as it’s input.
Please look at the datasheet for your PSU to know which connection that signal is wired to.
From the Smoothieboard, you need to connect :
One GND pin to the Ground connection on the PSU
One of Smoothie’s PWM pins to the PWM input on the PSU”

So they only connect one cable, namely the PWM signal with the PSU!
The PSU has two inputs:
L = switches the laser on and off
In = controls the power of the laser

If the PWM is clamped from the board to the In of the PSU, L would have to be constantly set to 0 (laser is always on) so that the power could be controlled from 0 to 100% and thus also activated or deactivated.

If the PWM from the board is clamped to the L of the PSU, the laser power must be set to a fixed value with a potentiometer connected to in, so you can no longer change the power via the software, right?

Or is it meant that with the PWM from the board you can switch the L from the PSU on and off so quickly that the power can then be changed?

I believe this is the most frequently asked and discussed question when upgrading!

Typically, the L is connected to a switch to allow you to manually enable / disable the laser output, and the PWM is connected to the IN on the power supply, but it does vary. C3D connects to the L pin to allow the test-fire button and the analog power control to still work, whereas the Mini Gerbil connects to the IN signal (I think - it’s been a while).

I switch the laser on with M3 and off again with M5! That’s going well!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.