Cad file imports as 1 mm segments

When I import a DXF file or a native cad file every line is imported as a string of 1mm segments. While it doesn’t effect the final burn, it can be cumbersome to work with. The same thing happens with PDF files. Is there a setting I’m missing? Or is this simply the way Lightburn is designed to work?

That’s not typical. It’s likely that either the parts are being exported that way or there’s something in the export that’s preventing LightBurn from importing the parts normally.

How are you generating the DXF files?

Additionally, you may be able to correct for the condition by selecting all parts of the design and then going to Edit->Auto-join selected shapes which should join all adjacent shapes.

Are the 1 mm segments disconnected, each with their own start and end node, or segments of the same path?

If they’re all part of the same path, try using the Fit shapes to arcs option in the Optimize selected shapes tool (Edit > Optimize selected shapes).

If they’re disconnected, you can try Auto-joining them as @berainlb suggests. You may also want to try increasing the Auto-close tolerance under File > Settings > File Settings > DXF Import Settings. The default is 0, so unless the beginnings and ends of each line segment are right on top of one another, they won’t auto-close on import.

Once they’re joined, you can use Optimize selected shapes.

2 Likes

Increasing the values in Optimize Selected Shapes solved the issue.

Thank you very much!

1 Like