Calibrated X and Y Axis, made laser very slow

I found out my calibration was off so I changed my 101$ and 101$ settings, but after changing them my laser is moving very slow, I tried to change the speed in the Move menu but nothing changes, how do I make it go the normal speed while keeping my new calibrated settings? Thanks.

$100, $101 would not directly affect speed.

Can you take a screenshot of Move window and also show what latest values for $100, $101 are?


Ive tried to change the speed but even after going up to 30000 it was the same speed.

Before changing it the speed was perfect and when I change the settings back to what they were originally it goes back to normal speed.

What were the original values for $100 and $101 and what are the new values?

Can you confirm that you’re able to burn dimensionally correct shapes with the new values?

You’re likely limited by a maximum speed.

Can you check to see if your machine is actually moving at specified rates? If you set the speed to 600mm/minute does it travel 100mm in 10 seconds?

Please run this command in Console and return output:


I dont have anyway to get the exact original value , but i think it was around 30. While i was calibrating it i input 40mm and the actual distance was 125mm. I can confirm that i am getting correct shapes with my new values. I also checked and my laser took about 12.5 seconds to go 100mm at 600mm/m. I checked if it was the same on other printing software (LaserGRBL) and it was the same speed. Thanks for your help.

I’m not really following this but let’s assume for the moment that calibration is correct.

Your $110-$112 values set max speed of X-Z in mm/minute. Right now all are set to 500 mm/minute. This makes sense as to why it took about 12.5 seconds to move 100mm at 600mm/m since you were topped out at 500mm/m.

I’m not familiar with your specific machine but you can experimentally increase these speeds. Keep doubling the value until the motor skips steps, then back off a bit to provide a level of safe overhead. Do this for X ($110) and Y ($111) discretely. You should be able to get faster speeds with X than Y.

$120-122 is acceleration. You could do the same for this if you were ambitious.

Note that in general the more you push these values the more your hardware will be stressed and pushed to mechanical limits.

When i mentioned imputing 40mm and getting 125mm i was referring to the calibration menu when you input requested distance and actual distance. I also got the original values back which was 250 per step for both X and Y axis. When i put the original values the motor when back to normal speed but was inaccurate again. I checked the $ values and they are identical for both the uncalibrated and calibrated settings.

Your original settings were 250 steps/mm and you’re now at 80? That’s a huge change. Have you changed anything on your machine? Belts, gears, stepper driver? I can’t imagine a machine being sent out so far out of calibration without some other explanation.

I havent changed anything hardware wise, i did switch from laserGRBL to lightburn and my calibration was off the whole time, i just fixed it today but then it got slow like it is right now.

Interesting. That’s just crazy that a machine would be off by so much (over 3x). I have to think something is missing but I’m just not familiar with that specific machine.

In any case, looks like you should now be good to go once you adjust max speed to your liking.

Thank you for your help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.