Cam calibration failure

After several calibrations still the position does not match. I do an update overlay and with the “click to position” the head are about 150 x 150 mm off. What do I do wrong?

Are you running the machine in absolute coordinates mode? If not, that would be the issue.

Where do I see that? In the controllers parameter there is Origin mode = Key Origin. (AWC708).

It seems to be a scale issue. The painted line is 200 mm. and the LB line are 150 mm. I can’t figure out why?

I believe the correct mode is “Soft Origin” - it basically means that wherever you place something on the workspace in the software is exactly where it will go on the machine. Without that, there is no consistent mapping between the design and the result, so the camera can’t work.

Ok. But the last picture shows the line, 200 mm, painted on the bed and when drawing a line on top of this line in LB it´s only 150 mm. So the question is if there are any scaling issue between the cam picture and the software? A few weeks ago I didn´t have this issue. But after a new calibration (because the settings where lost after upgrade to 9.07) this appears. Is it important to choose the right standard or fisheye lens when calibrate?

The scale setting have to be 100. Nothing else. If other than that the calibration doesn´t being correct… Erlier calibrations did I set the scale to about 250 because of bigger paper.
Bug or not?

If you aren’t running in the soft origin mode, the mapping between the workspace and real world locations will be wrong, but it shouldn’t affect the scale, just location.

The camera targets at 100% scale are exactly 180mm apart. Based on what I see in your view in LightBurn, that’s exactly how far apart they are (in that view). If you’re saying that in the real world, the markers are much farther apart than that, if previously ran the calibration markers at 250% scale, if you re-used those markers but told LightBurn 100% scale this time, that could explain the difference.

Hi.
I really don´t know what I´m doing wrong…
I follow your video of cam calibration. My score is under 0.1 every captures. I set the scale factor to 240 because of large sheet (and bed). I have to position the head and push the origin button before I start the engraving. After finnish I do an update overlay. The picture does not fill the entire machine area in LB and the laser position goes wrong. I have done this before in earlier versions and it went as it should be.
The work mode in the AWC708 is soft origin.
Have I missed some settings in the software/hardware?

Before above, I did a calibration with scale factor set to 100. Then the overlay capture looks nearly good but have some small missalignment when moving the head to a choosen spot. I assume the precision will be better if scaling up when aligning the camera with higher scale factor.

Best regards

The fact that you have to manually position the laser and press the origin button before you start feels incorrect - if the origin mode is set properly in the controller this should not be necessary.

The precision should be better when using a larger scale factor. If you exit out of the alignment wizard and then go back through it, you need to set the scale the same as before - it does not remember the number. I have seen this happen a number of times where someone exited for a moment to change a setting, then went back through, forgetting to re-apply the scale (it defaults to 100). If you did this, it would explain the scale difference.

It seems to be a good explanation! I will do a new cam align with the same scale factor. I think I missed that.
But what should the origin setting be in the controller? I have tried different and either it will start from the absolute (0,0) and do the markings from here or it will start from the latest origin point.

I don’t have an AWC set up here at the moment - I’m in a temporary home without the space to have machines until next month. There should be a controller mode where the art you place in the workspace in LightBurn goes to exactly the same location on the bed of the machine. I thought it was “Soft Origin”, meaning the software sets the origin. I’ll see if I can set up my virtual laser with the AWC controller tomorrow to verify this.

Ok.
Here are the settings for AWC708 (video)

I realigned the cam with the right scale and now it´s right :slight_smile:.

In the laser controll window in LB I think it was more options in erlier versions?
The green origin mark I cannot move to the absolute zero in Lightburn.

image

It’s because the controller chooses it. There were more options before because I was hoping I would be able to override the setting in the cut file somehow, but they never worked properly. It’s not possible in a way that works nicely with the controller setting.

Maybe I should switch over to Ruida controller :slight_smile: .
I have a 6442g unboxed…