Camera calibration issue help request

I went through the camera calibration and alignment. All my capture values seemed to be good. Made the alignment pattern, all seemed well. Now when I update my overlay and drive to a location it is never in the right place. The 3 location for the test patter, if I click on the center of the target and mark it with a pulse the actual location is 30 mm to the right and 10mm down. The 2 target seems to be about 30mm above and 10 mm right. The 1 target pulse is about 30mm to the left and 10 mm above. The 4 target is 30 mm below and 10 mm to the left. I am using an 8MP 110 degree lens on a 1300 x 900 bed. Also kind of disappointed that the images are not very sharp. I focused it in as best I could, and no there is not a film on the lens, it did not have one when the camera arrived. Any suggestions on how to get this dialed in?

What controller are you using in the laser? I tried to look at the ‘Machines’ section of your user profile but you don’t have anything useful there.

For focus, I recommend running the Microsoft camera app in full screen mode. Twist the lens to get the best focus you can.

When doing the alignment, scale the job up as large as will fit on your machine - you should be able to scale to 475% without a problem, and the larger alignment pattern will make the results more accurate.

It is a Ruida controller. Not exactly sure which model, and not in the workshop right now. I moved the camera closer to the bed, redid the pattern search, and ran the pattern at 100%. Seems to be better. Still not great but better. Would be nice to have a CCD camera with pattern search that could be mounted on the head, would be a much more effective production level solution.

Head mounted camera support is in progress.

I hooked up my camera and ran through calibration. When I try to run the alignment the machine tries to move to the outside and back of the machine, causing grinding. When I manually move the laser head I get an Out of boundary error message. It is like the lightburn software is backwards when sending code to the shapeoko.

Or maybe the setting for ‘Machine Origin’ is set incorrectly for your configuration. Have a read of this to help: https://lightburnsoftware.github.io/NewDocs/CommonGrblSetups.html#shapeoko-xcarve-and-other-negative-workspace-systems

That was the problem, but the 812 is in mm and I am using inches so I went to X-30 y-30 and it was too far forward. I kept adjusting to get it to a good space size and run the calibration. It is working. Thanks for the solution. When I typed in that macro last night I kept getting the grinding on the front end and wasn’t thinking about the factors being too large.

Would be good. I have tried all sorts of different mount positions etc. can not get the camera to calibrate properly. Should have lit my $140 on fire instead. Oh well.

You don’t need the camera mounted at all to do the lens calibration, and in fact, we now have calibration presets for all the cameras we sell, so you only have to do the alignment, not calibration. When you calibrate, can you post an image of the calibration page just before you click the ‘Capture’ button? I’m guessing if I see that I can tell you why you’re having trouble.

The most common user issues are documented here: The camera doesn't find the lens calibration pattern (no pattern found)

Can I just return the camera that you sold me without calibration presets for one that has calibration presets? I’ve spent way too many hours dicking around trying to get this thing to work. The camera will “calibrate”, all the values I am getting seem to be good, but when I go to make a cut, everything is way off. By 25-30 mm, not just a couple of mm. It’s borderline comical how bad it is.

We have calibration presets in LightBurn for every camera we sell. If you calibrated and got good scores, then the issue is something else. To be much help I’ll need to know:

  • What kind of laser you have (your profile just says “LightBurn” in the ‘machines’ section)
  • Where you have the camera mounted
  • Which direction the alignment is off by

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.