Camera Lens Calibration Black Screen under Linux

First the good news: I have Lightburn installed on my beefy Linux desktop in my office, and the camera works fine without the problem below.

My Linux laptop out in the shop has the following issue: After clicking Tools, then Calibrate Camera Lens, I am greeted with the window where I need to select my camera device. If I select my USB 2.0 camera OR my webcam (built in to my laptop) both result in a black box shown on the left. I ran Lightburn from the command line, and the only thing that happens is that I get a “Setting res:” message, but nothing else. I tried turning on Debug mode in the Help drop-down menu, but can’t seem to find where it might be writing its logs. It feels like there is something going on with how Lightburn is grabbing the video devices as it happens with both. If I exit Lightburn and open up my webcam software (Cheese) both work flawlessly, so it’s not a hardware issue.

As I said, I’m more than hopeful that this is an easy fix, as it seems to work flawlessly on my Linux desktop machine.

Working Desktop: Linux 4.15.0-47-generic Ubuntu SMP x86_64
Struggling Laptop: Linux 4.18.0-17-generic Ubuntu SMP x86_64

Thanks for any leads you can throw my way! :slight_smile:

–C

It’s very likely a version issue with the libraries used. LightBurn on Linux uses GStreamer as the capture back-end, but I don’t know a lot more about it. It was built on Ubuntu 16.04 LTS. (Linux is the OS I know the least about)

Thanks for the heads-up. I’ll double check my gstreamer versions between the two machines and see if there is a difference.

Follow-Up: I checked the gstreamer versions and some of the libraries were slightly different. I know some of the dependencies of other applications required the updated changes, so I rolled back the laptop to Ubuntu 18.04 LTS (Long Term Support) and it worked first try!

I purchased my LightBurn license specifically BECAUSE there was a Linux version. Thanks for making this version available! :slight_smile:

1 Like