Can I change "native world view"of a Ruida controller?

I’ve used RabbitUSA lasers for a long time, and I’m now upgrading an older Kern laser, using a Ruida 6445 controller, with the end goal to facilitate use of LB.

I’ve made a lot of progress, but I’m puzzled about something. It seems that the foundational “world-view” of the Ruida controller that X axis home position ( and corresponding limit switch) is at the rear RIGHT corner of the bed. That seems to be how the Rabbits are set up. For a lot of reasons, it’s best on this Kern if the home limit switch is at the LEFT rear corner. How can I set that up most easily?

I know that I can flip a lot of things by flipping coil polarity, and exchanging end-stop input positions, but i’d like to keep things simple if possible. Am I overlooking some oddly-named parameter in the machine setup dialogs?

Do you mean you have set the home in Lightburn to left back and it still homes to right back?
image

HI, @Enno.

No, not in Lightburn, but down at a lower level, within Ruida-land itself. The things that happen when I turn on the machine, or press the RESET button on the keypad. Put another way, it’s the underlying low-level reality to which Lightburn must conform to, by us telling LB where X0Y0 is.

Perhaps this document may help? Configuring a Ruida - LightBurn Software Documentation

Specifically, this section:

Homing, Directions, and Travel

A DSP laser will have homing switches - one on each axis. They might be physical lever-type micro switches, optical beam-break switches, or inductive proximity sensors. Locate the switch at the end of the X axis, and the one for the Y axis.

When you power up the laser, the first thing it will do is move toward the corner it thinks those switches are at to home itself. If it’s moving in in the wrong direction, you’ll have to hit the ESC button on the controller itself to stop it.

Bring up Machine Settings in LightBurn, and go to the Vendor settings section at the bottom, and open the X axis and Y axis Settings. Near the top of each will be three check boxes:

  • Invert Keypad Direction

  • Limiter Polarity

  • Direction Polarity

The first (keypad direction) controls which way the arrow buttons move the laser. The second (limiter polarity) controls which side of the machine the laser moves to when looking for home, and the 3rd (direction polarity) controls which way the motor moves in general.

There are only 4 possible combinations of “limiter polarity” and “direction polarity” for each axis. I can’t tell you which is the correct combination, but change those settings for the X axis until it moves properly when you power the machine, then do the Y axis. Once these are set, the next steps are easier.

When the limiter and direction settings are correct, check that the keypad arrows on the machine are moving the laser in the correct direction. If not, toggle the ‘Invert Keypad Direction’ button for whichever axis is wrong.

You will also need to set the ‘Max Travel’ value for the X and Y axis - these numbers dictate the length of each axis, and together define the size of the work area of the machine.

1 Like

Thanks, All. I’ve gotten things moving in the right direction, but I’m seeing odd things down in Ruida-world. Scaling and speeds are not right, and other things. I’m wishing there was a scholarly forum (like this one) that could help with the black-box world inside the controller.

Here’s a for-instance. I have configured the machine to be 2438 x 1200 mm. (An approximation of 96x48".) Sometimes, at power-up, the keypad display will show X=10,000 and y=10,000. What the heck is THAT all about?

I spent many years doing systems integration work, so this is not a new feeling. IMHO “the truth is inside the box”, and on a good day you have the means to examine the code, or system state info. On a less-good day, you see weird stuff and scratch your head. :face_with_monocle:

I believe that 10000 is the Ruida default for “I have absolutely no idea where I am”.
If for some reason the machine is unable to correctly home itself it displays 10000.

yup if you disabled or interrupted the home sequence at booting.
If scaling and speeds are not right you did not set the steps right which will probably solve both problems in one go.