Can I change the travel speed on a C3D?

Hi, I apologize if I am asking this in the wrong category or in the wrong manner. I have a blue/white K40, with Cohesion3 board, and running Lightburn. I have been having issues forever with the laser moving very quickly from one layer to the next, or if it travels a long way to start the job. The issue is that most of the time if it travels very quickly, it makes a noise, and doesn’t start at the right spot. It travels fine within the layer moving from one area to another within the layer usually. My question is this: is there a way I can set the travel speed when the laser is not running? I have it set at 50 on the move tab, so there is no issue framing or moving within the tab. I have ruined so many projects because when it travels to start a new layer, or even to start, it goes too fast and doesn’t travel to the right spot.
I hope I have explained this so you can understand. I know “0” about gcode and firmware, and all that stuff, so any help you can give me would be appreciated.

If you’re running Smoothieware on the board, there’s a setting in the Config.txt file called “default_seek_rate”, usually right near the top of the file. Lower the number next to it to change the default speed used for G0 moves.

It’s in mm/min, so this value:

default_seek_rate                            24000

… would be 300 mm/sec (24000 / 60)

6000 would be 100mm/sec, 12000 would be 200mm/sec and so on.

Power off the controller, pull the SD card out and put it into your PC, edit that value, put it back in the C3D, and power back up again.

I haven’t run laser for a while, but I am pretty sure I changed the smoothie software to Grbl a while back.

Ahh, well in that case you have a few choices:

  • Go to Edit > Machine Settings and change the X & Y Max Rate values to something lower (this will reduce the travel rate, because it’s the maximum speed of the machine)

  • In the console, set a macro to use on startup that does G0 Fxxxx where xxxx is the speed you want G0 moves to go in mm/min. LightBurn never overrides this.

  • In the machine settings, lower the acceleration a little. Usually it’s acceleration, not speed (or a combination of them) that causes missed steps. Lower acceleration can help you hit a higher speed, and lower top speed can let you get away with higher acceleration, sometimes. Lower accel tends to be more robust overall though.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.