can i connect a vigotec vg-l7x with lightburn ?

hi, i have been trying to connect my diode laser with laserburn for a while.

is there any possibility to connect it ?
the original software is not really great.
maybe someone has experience.

thanks
Greetings
Marcell

This is from the Vitrotech github page:

"Vigotech made some design choices that make this machine usable ONLY with their VigoWorks software. This means that if you buy this machine you will not be able to use it with other programs that use the GRBL standard (like LaserGRBL, LightBurn, T2Laser, etc).

Luckily for you, an alternative firmware has been written! With this firmware flashed on the ESP32 chip you can use LaserGRBL and all these programs, instead of the inconvenient software supplied!"

Check out the first link, you may want to do a firmware change :slight_smile:
Good luck, take care.

Cool. Thanks a lot. :slightly_smiling_face::slightly_smiling_face::slightly_smiling_face:

If you’re satisfied, mark the solution as ‘solved’ :slight_smile:

I’m sure you’ll find it advantageous to upgrade to something that more generically controllable.

Take care, good luck. :slight_smile:

mhmm too bad…the link for the library no longer works. :neutral_face: do i need the Nodemcu 32s?

What link? I just went over and looked at the replacement firmware.
Maybe I misunderstood you. :frowning:

I think I do not quite understand. I have now downloaded the software arduino ide.
Then tried to download the library for the esp32. But the second link is probably no longer up to date. In the instructions it says that you should first pack the arduino ide together.
Am there unfortunately not so good in it.

The computer on your controller is aparently a Node-32s. This software replaced what’s on there now and would allow the use of Lightburn and others.

Usually you’d use the Arduino IDE interface to build and upload the new software to your controller. You can usually find the compiled software that would eliminate the IDE. But you need something to get the new software to your controller board.

There are a few python programs out there to do that. There is also a lot of Node-32s software libraries out there. The one in the link is missing.

Did you understand the procedure in the top link for you machine? You need to spend some time with that so you understand the operation.

Yes, exactly
I have understood that so far. I have also already asked google. But I’m not sure if that’s the same thing that should be in the link:

I don’t know if there is anything there that I can use.

Thanks
Marcell

You’ll probably have to try and load a new version and see if it works. ALWAYS find the original firmware for a replacement, just in case.

Might check out the site that had the initial information and see if anyone there can assist. It seemed to me they had the firmware already. Don’t have time in the next couple of days…

Okay, thank you