Can not export any file types

I can not export any type of file, ai, svg, dxf. any type that I try to export looks like it saves it, but I can not find the files any where. on win 10,and newest lightburn version. HELP PLEASE

Where are you trying to save them to?

to desk top or a file folder, need to export a dxf to take to a machine shop to cut a panel that I need.

There’s no magic - if you select part of the project, it will export the selection. If you don’t have anything selected, it will export everything. If your file contains only images (bitmaps) it won’t produce content, because those aren’t exported, but you should just get an empty file.

You’re saying that no file is produced at all? Is there anything strange about your system? Do you have anti-virus software running that might think LightBurn is a threat for some reason?

can not find no file at all. win 10 no anti-virus software, I have been doing computers sence comadoor 64 and im stumped.,


I have the same issue on Linux Mint. When I want to export any graphics, not output file is created.Regardless where I want to save. I assumed this could be a limitation of unlicensed software, but with fresh license key the issue is the same.

Thanks for the any advice in advance!

It’s not the license - there are minor differences in the code that produces the filename to save when using “Save Project” compared to using “Export”, and I think that might be the issue. It might be an internationalization issue - does your user name on your computer, or any other part of the path, contain any special characters, like letters with accents? I suspect this is the cause.


The path, username and computer name contains only valid English characters, without space or special characters. I know what you are talking about, special characters can make quite a crazy situations…

But I found out what could be the problem: when I export a file, then normally I choose the extension (ai, dxf, svg) from drop-down menu and the filename whithout extension. That’s how most software works. In such case no file is exported in LightBurn. However, when I add a file extension to the file name “example.svg” and choose the export type “svg”, then the export works OK. So maybe it’s a linux specific stuff, I don’t know. I am happy to assist in resolving this issue.

BTW, exported svg can be open in Inkscape, but dxf and ai files are not readable by Inkscape.
QCAD can read the dxf, file, I have no opportunity to read the ai file with Adobe products. But I am happy with svg files exported. I know that ai/dfx file types/versions are not “standardised”…:wink:


LightBurn’s DXF files can be opened by AutoCad, and it is extremely fussy, so I’m not sure why InkScape wouldn’t load those.

AI files exported from LightBurn are in a very old format (v3.0). Modern AI files are actually just PDF files, with the true AI file embedded in them, and I believe InkScape just treats them as PDF. Since LightBurn AI’s aren’t a PDF, they don’t work there.

I will look at the extension setting - it’s supposed to be automatically added when you choose the type, but perhaps not in Linux - I recall having a similar issue on MacOS, and that is Linux based, so it might be different behavior on both.

The behavior is apparently in the Linux (and OSX) native file dialogs. On Windows, if you choose an extension but don’t type one, it adds it for you. On Linux / OSX, it does not, so I’ve written code that will force extensions for you when exporting, or when saving to machine files. This will be in the next release.

I tried saveing adding the .dxf,.svg and now it saves and im on win 10?

I checked on my own system (Win10) and it worked without me entering an extension manually even before the change, so there might be an OS setting involved somewhere.

The changes I’ve made will force the extension regardless of platform, so they’ll work on Win10 as well.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.