Can not fix Homing and Y axis

New to this group and using laser. Setting up the laser with light burn I had many problems. I had the
machine for 2 weeks. Reading comments from this forum has helped allot. I still have two problems that I cannot resolve.

Let’s start with Y axis will not move from line 0. When I move the laser, here is my message.

G-code motion target exceeds machine travel. Machine position safely retained. Alarm may be unlocked. (Right-click the ‘Devices’ button to reset the connection)
On or near line 2:
Stream completed in 0:00

I have replaced the USB cord. That in itself resolved some problems. I have reset the connection. Restart the computer. The program is set on absolute coordinates.

Next problem is homing. I have tried all suggestions that I can find in this forum and documentation that I could find for setup of the lightburn program. My problem when you click the home button the machine wants to move to negative X axis.

I am amazed you had these problems! I just bought a Sculpfun and only had one issue. Have you changes any of the $$ parameters?

For a start, Enter $$ in the Console window and copy/paste the output here. Based on what you said and we read, expect to adjust settings.

Do the same for $# too.

Also include what frame size you have, and confirm that you have the two HOME switches on your machine…

Which model do you have?

If you want to use the homing function, you need limit switches. Those are included in all Sculpfun lasers starting with S30, but not with S6-S10. A guide is here:

Only then you can use absolute coordinates. Though, in most cases you don’t need absolute coordinates, it’s much easier to use “current position”. Guide on that:

The thing about the wrong movement of the homing function has nothing to do with LightBurn, it’s a laser setting. Make sure to read both articles above, they should explain it. If not, let us know :slight_smile:

Waiting for connection…

Port failed to open - already in use?


Waiting for connection…




[MSG:Using machine:XY DLC32]


































































I think all your issues revolve arpund you trying to Home your laser.
To fix, in the Console window, enter:
Homing requires 2 switches and Hard limits requires 4 of them. Your machine has none.

I have Soft limits enabled ($20=1) on mine to prevent travel beyond the X & Y limits. If you get an Alarm 2 when trying to execute a burn, it means you are telling the machine (with your project) to go beyond the physical limit of the machine.

Once you fix the $$ parameters, study on how to operate with a User set origin. This can be done because many others out there are using the same machine as yours.

Technically, hard limits work with any number of switches, but it only protects the laser at the ends where they are :slight_smile: So with the standard two switches it prevents crashing into left and front, which also protects the switches itself.

You still didn’t write which model you have, or didn’t I see it? Your board is at least an S10 version.

“Your laser: Machine is a Sculpfun S6 Pro”

I would think 20 switches should be enough. :rofl:

I have a s6 pro
I made changes without a fix. I changed the y axis to -410 and I can start a burn but it will exceed limits before
the burn is complete.

If you don’t have limit switches, move the laser manually to the front-left. Then turn it on and connect USB. The laser takes this point as 0,0. Now you could use absolute coordinates, but I would still not recommend it. Change to “current position” as starting point and start your jobs.

No go still exceed travel limits

I can move the laser with the buttons only if I start with the laser head in the left rear position. I use the G10 command to position the laser in the left rear. Changes device settings. Start a burn get out of limits.

If I have no power to the laser should light burn have a laser ready or should I have disconnected.

That’s wrong. Without limit switches, you can’t use G10 commands. Doesn’t make sense. So, send “$RST=#” in the console to delete everything you set.

Both :slight_smile: No power to the laser does not mean it’s turned off. The mainboard is powered by the USB connection and the laser is still running. Only the motors and diode can’t work. That’s why you need to turn off power AND disconnect USB to make the controller reboot. So, if you turn off power, it’s ok that LightBurn stays connected, but what you want is a complete disconnect, so remove both cables. If you then turn the laser on again, the position it is currently standing is 0,0. Confirm this by reading the position in the move window.

Understand the Laser ready. Sent $RST=# the rebooted. Using move button still exceed travel. Rebooted and restarted Lightburn same problem.
Copy of my console:

Waiting for connection…
[MSG:Using machine:XY DLC32]
Starting stream
G-code motion target exceeds machine travel. Machine position safely retained. Alarm may be unlocked. (Right-click the ‘Devices’ button to reset the connection)
On or near line 2:
Stream completed in 0:00
Grbl 1.1 [‘$’ for help]
[MSG:‘$H’|‘$X’ to unlock]
[MSG:Caution: Unlocked]

Using the move button, I can move the X axis. If I manually move the laser to Y axis 400 it will move to a negative position. So with this action working I thought the machine need to have negative Y axis settings. Change all required setting, Set the Origin, Using the move button I can move the laser both X and Y. If I try to frame or run a burn I get out of limits. I reset everything back to 0,0.

If you manually move either axis, the controller no longer knows where either the carriage or trolley (Y or X) is located. It only knows the last position it commanded. For this reason, you should never manually move the machine after you power it up.

Please confirm all three of these parameters are now =0.

Power up the machine and set the origin to the left-front location. Draw a box 380mm x 380mm, select it, and use preview to show the burn pattern. Set laser power to 5% and speed to 3000mm/min and try to run it.

If at ANY point you get an alarm, save the project. Then upload the Lightburn file here and tell us when the alarm message appeared and what i said. One of us should be able to determine what is happening

You mean using the move buttons? It looks like the laser starts correctly. All positions are zero. What happens if you send the laser 10mm to the right and 10mm to the back? You should get 10,10 as position. Nothing negative.

It looks as if all is working. I ran the square as you stated and then a couple other small burns. Shut down light burn and the laser disconnected USB. Restarted and ran square again and it still working.

Thank you for the help

Not exactly what I asked for, but if you are satisfied, I am done. :100: