Can not save LightBurn file as "GCODE" file type

I prepare my design using the LightBurn, then click on the “Save GCODE” button. The file is saved, but as “GC” file type, not as a “GCODE” type. My CR-Falcon Laser does not recognize “GC” file type, and only works with “GCODE” file types. Please help me with this problem, thanks.

You can choose any extension you like. Either at Save time by specifying the extension or by simply renaming the file after it’s saved.

1 Like

Thanks, I am not talking about the file name, file type like GCODE file. The name of my file is “Framed” but it is “GC type” and I want it to be “GCODE” type file. because my laser needs a GCODE type not GC type.

The file that is saved is a text file. The extension does not matter so you can make your file anything you want. Example; file.gc can be renamed file.gcode or file.nc ect. It is the same file regardless of the extension.
You can test this yourself by opening the saved file in a text editor.

you only have to disable “hide extention” on folder properties