Cannot Capture Image

I cannot for the life of me get the software to “Capture Image” after installing the camera. Here is what I have done.

  • Connected camera, it shows up in Lightburn and in FaceTime apps. (on a Mac mini)
  • Focused the lens.
  • Calibrated camera lens (using the 120 degree Lightburn camera, I clicked on the preset)
  • Calibrate camera alignment did this with wood and paper. Click next and capture image doesn’t do anything.
  • I am using an active USB extension, I tried without this directly into the Mac and same issue.
  • The image is blown out so I turned the lights off, still nothing.

The documentation mentions a dot matrix that I need to print, I did not do this as I don’t have a regular printer handy, but I am assuming that isn’t the issue as the software itself mentions this new calibration pattern. One note, with the paper it cuts out the inside of the pattern so its pretty useless. but on the wood I got a good image

the dot pattern will get you better accuracy

I have now also tested on an Intel MacBook (2017) and have the same issue. Both are latest Lightburn and Big Sur releases.

Are you using the Big Sur specific release of LightBurn? (we have one now, as a number of things in Big Sur are different enough that it required splitting the development into two versions). You can find it here: Download & Trial - Try before you buy – LightBurn Software

If you aren’t using that version, please install it and give it a go. If you already are, let me know, and I’ll have to try setting up a camera here on my Big Sur dev system to see if I can reproduce this. I can also have you turn on debug logging (in the Help menu), then send / check that to see if there are any errors in the generated log.

I have confirmed that I am on the Big Sur version by redownloading and installing. See attached debug log after trying to calibrate alignment.

Thanks! LightBurnLog.txt (8.8 KB)

I can see the sequence of triggers happening, and it looks like the camera isn’t sending (or I’m not getting) the “ready to capture” event when the preview feed is moved from the initial camera selection page to the target capture page. I’ll go through that code and try to reproduce - it’s likely going to be tomorrow or the next day because I have a few other, slightly higher issues to address first that are still lingering from this release that I want to get pushed to our test group, but I should have what I need to address it.

A thing to try - If you exit, then re-enter that screen, and quickly click ‘Next’ to get back to the target marker page, I’ve had one other user report what appears to be the same issue (same OS too), and he was able to get through using that - when re-arriving at the capture page it worked. Clunky, but if it moves you forward it’ll help for now.

This looks like something that changed in Big Sur and is affecting code deep inside the framework LightBurn is built on - that framework is what provides the access to the camera system, so I may have to try to replace it, which is … complicated. I’ll investigate more and see if there’s work in progress on the framework itself to address this.

1 Like

Thanks for the update.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.