Cannot connect Comgrow Z1 to LightBurn

I have a new Comgrow Z1 laser that I’m excited to use but I cannot get it to connect in LightBurn. The console only shows waiting for connection, but the laser says ready. I have installed the drivers that came and it it is showing up as “USB-SERIAL CH340 (COM5)” when I connect and turn on the Z1. I configured the device as GRBL → Serial/USB → 400mm x 400mm → auto home, front left. I am on a PC running windows 10, but I also tried it on a laptop running windows 11 with the same results. I spent several days trying to figure it out before getting a replacement from Amazon. The replacement is doing the same thing, so I’m assuming its me. When I turn on the machine I can hear the fan, the red light is on and the green light flashes. It does not home when turned on, but it has not successfully connected to any software yet.

2 things to try:

  1. Enable “Enable DTR Signal” in Edit->Device Settings
  2. Experiment with baud rate between 115,200 and 921,600

Try every combination of those 2 if it doesn’t work immediately.

The 921,600 worked and its connected now. thank you for the help

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.