Cannot connect OmTech 60W, Ruida to MacBook, MacOS Monterey 12.7, LB 1.4.03

After a seasonal break from using OmTech 60w, I could not connect to my laser. I updated my license, installed LB1.4.03, updated MacBook Air to latest OS, Monterey 12.7 and still am unable to comment. I’ve run LB via ethernet for over a year prior to this. OmTech and MacBook indicate their presence on my network. I have manually added the Rudia controller, rebooted MacBook x4(including in “safe mode”), and Omtech x4. Is LightBurn no longer compatible with Mac OS? If LB is “compatible” , how do I connect?

First, do a physical check to make sure all cables are properly seated.

A few questions:

  1. How is the Ruida connected to your network?
  2. Check the network page on the display panel and confirm IP address.
  3. Are you able to ping the Ruida’s IP address from your computer?
  4. Does the laser otherwise work? Have you tried transferring RD files over USB drive?

Thank you for response
My MacBook is connected to my net switch and the OmTech is connected to the switch also. It’s been working up until I took the summer off of shop fun. I just eliminated the network cabling by replacing MacBook to controller cable with a new ethernet cable direct from MacBook. It didn’t change anything. I’ll work on verifying the IP address… And I’ll try to learn how to ping from my MacBook…

Pinged IP address; average 72Ms (15-160 Ms) that is cabled as original. Haven’t tried using usb as I’m under the impression that Rudia doen’t like Mac USB. Its worth a try…Of my 1000 cables, I don’t have a usb male to male cord…

I’m having a hard time following this. It sounds like you’re possibly describing two different historical states of the networking.

If something has changed, what was the previous state and what is the current state?

Also, I assume your Macbook is also on wifi but correct if this is not the case. Does that mean you’re both hard-wired to the switch as well as through wireless? If so, can you describe your network topology? What are the various IP addresses for the Macbook wired and wireless as well as IP address of Ruida?

Please provide the following:

  1. take a photo of the Ruida display panel showing network
  2. capture the output of the ping command from Macbook to Ruida
  3. full screenshot of LightBurn with Laser window showing
  4. screenshot of Edit->Device Settings

Can you elaborate on what this means? It’s not obvious in context.

1 Like

This should only work if you configure your Ethernet port on the Mac to have a static address in the same domain.

The Ruida is a static device and your computer expects a router or something that will issue it an IP…

When were you able to ping it?


OK… I got redirected to domestic duties while troubleshooting, I apologize for breaking our session.

I hooked a rj45 cable direct from MacBook to the Ruida Controller in the OmTech ( I did not know about altering the MacBook ethernet port). Needless to say it didn’t change the connection issue. I reconnected the MacBook and OmTech to the network, and pinged the connection. Here is the screenshot of the results.
Screenshot ping

Here is screenshot of Ruida Console with IP address .

Here is a screenshot of the LightBurn Devise connection for the Ruida controller.
Screen Shot 2023-10-07 at 10.17.16

Here is screenshot of MacBook ethernet screen.

MacBook is also on WiFi, here is the screenshot.

This morning I was able to save a Lightburn file in .RD format to a flash drive, insert it into the OmTech, upload it and the OmTech worked as advertised.
I have been unable to locate a USB male to male cable so I am unable to hook MacBook to the OmTech USB port.

Since last spring when I was using my laser routinely, the following things have changed: I updated my LB license, Updated LB to 1.4.03, and updated my Mac OS to Monterey 12.7

I appreciate you trying to get me reconnected, Thank You

Is your whole network domain This is not common, but it should work.

I stated that the Ruida is static you have it set for a dynamic ip…?

It says connected, what does Lightburn do?

I just got a macbook, still learning to drive it…


Good afternoon Jack,
I have only owned Macs since time began… but I’m a casual user. I love my Macs, I know nothing of the Windows world.
Thanks for working on Sunday, I wasn’t expecting that.

Re; network domain…I don’t recall ever purposefully setting any parameters for my iMac, router or any other devices except the OmTech when we ( my daughter and I) originally set it up December of 21.

Re: static or dynamic IP… I don’t know the difference and I don’t see an option for changing it…

LightBurn still says disconnected
Screen Shot 2023-10-08 at 14.52.09

I don’t work for Lightburn…

Got the shaft from Apple long ago, don’t buy Windows or Apple products… Happen to have inherited a Mac Pro Notebook I’m on now.

Most routers create a user domain of from the vendor. Unless you changed that, it’s probably your problem connecting. There is no fixed address domains, only suggested ones.

When a device first connects to a domain, it asks (via a message to a network address of, the DHCP server that it’s requesting an IP for it to use on that network. The router usually has DHCP software on board to issue addresses.

The Ruida has it’s address set, via the front console (Z/U → IP address, I think). It does not ask for an address, it uses it’s pre-programmed IP. This can be a problem if your DHCP server doesn’t know it’s static. On my Linksys router, I can see it on the Lan network map, click on it and I can tell the linksys that it’s static.

Look at the devices on your network and see if they are in a different domain. It sounds like someone has changed it… usually they are

Change it to something not in your network and google your router on how to set that address as static or bind it to the Ruida MAC address.

You can’t just plug a network cable from a device → computer.

Make sense?


Thank you for responding, whoever you work for, you’re still willing to help me out!.. Doesn’t make a lot of sense to an old hammer mechanic such as I… but I’ll study it a bit and see what I can see. My MacBook IP address is and works great on the network… I’ll google my router info, and look at my domain name on my iMac too. What confounds me is it all was working before seasonal hiatus and software updates.
I have a windows “burner” laptop on order in case Lightburn refuses to play with my MacBook, I’ll be really confused then. It’ll take some time to study this.
Thank you.

Since this occurred during a time out, it might be that your router issued a duplicate IP to another device.

Sounds like your domain is so the Ruida should be there. The only thing I can think of is what I mentioned.

In your browser, can you see the laser via your router setup? If you unplug it does it go away?

If it’s on your network, and you haven’t dealt with it being a static device, then I’d fix that first.

I still haven’t found how to search my lan on the mac… working on it… so far I’m not impressed.


I was trying to map my network from my iMac… unsuccessfully, it only showed my printer and my grand daughter’s IMac
(my old one). Like I said I’m not IT savvy , I’ll have to study it. I obviously have an unrealistic expectation of plug-n-play functionality. Reading LB forums, seems like connectivity is a recurring issue.

Better known in the industry as plug-n-pray

You might try arp -a from the command line and see if it know what it is…

I’m sure @berainlb knows how to do it… I’ll keep looking myself, it’s all new… That or I’ll have to fix my Ubuntu box that went ti**s up on me the other day.


On my iMac, I typed in arp -a, on the terminal utility… and this is what popped up

My IMac is also on the network, and I pinged OmTech, with this result

When I pinged the MacBook , this is what I got… (is it not connecting?)

Ok, I bought a USB to USB cable, connected MacBook to OmTech… ran Lightburn USB connection wizard. No device found.

Loaded older version of LB, 1.3.00, rebooted LB, manually set Ruida IP address… No connect

I can see it at the 150 address in your arp -a scan.

As far as I know, Lightburn doesn’t interface directly to the Ethernet hardware port, it’s handled by the os, and the Ruida seems to answer the arp -a request.

Did you unplug it and ensure that address goes away? Just making sure you are seeing the Ruida and not some other device that has been assigned the same address.


Just unplugged ethernet cable for OmTech, ran arp -a, here are the results…

Screen Shot 2023-10-10 at 13.45.14

.150 shows up twice, ?? maybe if I assign the Ruida controller a new IP address it would work, I’ll try it

Jack, you’re a genius… I changed the IP for the Ruida, and manually updated the Lightburn devices and Eureka, OmTech says “Ready”. I’ll give things a try now…