Cannot connect to Lightburn after latest update

Did something change in latest update to affect USB?

I have a NeJe Master 2 3500 working flawlessly with Lightburn. Updated the board to add homing and it all has worked fine with NeJe software, so I dove in and purchased Lightburn. No issues, blown away by all features and how well Lightburn worked with the NeJe that I upgraded the 3500 head to a NeJe A40640 40w module. Swapped laser modules and tested first in NeJe software and all worked. Closed the NeJe software and started playing around in Lightburn for a few hours with no issues, then closed it all up and went to bed.

Today, updated Lightburn to 1.1.03, updated USB driver to 3.5.2019.1 then went to grab lunch. Came back and tried to connect to A40640 and just get “Waiting on connection”. Closed Lightburn and tried in NeJe software and no issues.

I notice that when using NeJe software, GRBL light on laser module is green (I think… but i know it wasnt yellow). When I connect using Lightburn, I hear a change in laser and see the GRBL light on the controller go yellow.

To troubleshoot, I’ve reset the laser (yellow button), changed com ports, deleted and rolled back USB driver, rebooted PC, created new profile in Lightburn, but am out of ideas.
I only suspect it could be software because I see changes were made to comm section because there is now a TCP/IP option which makes me wonder if something change in latest update to affect USB?

Hopefully tonite I can find time to look at the GRBL code in the laser, maybe something change there, but in the meantime I wanted to inquire if anyone else was having issues and if any suggestions on what to look at.

LightBurn has no role in the USB connection. It simply communicates to the port as a serial device. As long as the port is working and available LightBurn can communicate with it.

Based on your post the USB driver update is the most suspect but hard to say.

Neje controllers house 2 different laser control firmware: GRBL and Neje proprietary. I don’t recall which light correlates to what but the light color indicates if it’s working in Neje mode or GRBL mode.

What version of LightBurn were you using prior to upgrading to 1.1.03? Can you confirm that your device type that you used in LightBurn is GRBL? When you recreated the device was it auto-detected or you created it manually? There was a change to iLaser device type that affected users who had mistakenly chosen that for their GRBL devices.

Can you connect to the laser using LaserGRBL? Would be a good outside test.

Thanks for the response! I didnt realize there were 2 firmwares in there, that explains why NeJe worked. I have my doubts it’s actually Lightburn that causing this, but it’s the one thing that did change and I do see mods to the com section, so there is at least suspect.
The board is definitely GRBL, I’ve been in the board a few times in the past to change settings. What’s odd is it did connect at first and worked. Changes to driver and update of lightburn were only changes. I did roll back driver to original, then upgraded to another, but no luck. I also tried a few variants when making new profile and none worked.
I believe I was originally using 1.1.02 but cannot confirm other then I updated it less then a few weeks back. I also noticed it did not find the laser automatically, but I dont think it ever did, or I just manually added it.
Great suggestion on LaserGRBL, that would be a good test, will do that when I get home tonite and follow back up. Should help rule out things depending on outcome. Thanks again for the suggestions!

Have you selected the port the laser is connected to? Here where it says, “(Choose)”?


Hi Oz,
Yea, I spent an hour going back to the basics. Selected the correct port, even changed ports and then reselected. Also created a new profile and tried some of the other GRBL options in the device settings.
What I notice, when I change the port to choose, it stops communicating with main board. When I switch to the correct com port, I notice the GRBL light goes yellow and hear a slight change in pitch to the laser.
Going to try LaserGRBL to rule out if com port issue tonite when I get home from work. If I cannot connect to LaserGRBL, then it has to narrow it down to something must have happened to the code in board and will dig through from that end. If it does connect, that may point to something within Lightburn changed.
Will report back tonite with my findings.

Do you know which LightBurn version you were using before you updated?

I believe it was 1.1.02.