Cannot cut multiple shapes or letters after GRBL upgrade and adding limit switches

I have an Atomstack A5 and recently upgraded the laser to the M100. I decided to add limit switches to my frame and reflash the board with GRBL so I can store my settings. After flashing the board with GRBL customized XY homing points, I got my laser to home correctly to the bottom left of the frame with the limit switches working.

The issue I have now is the laser will cut simple square boxes fine, however if I attempt anything other than a simple squares for example, lettering, a circle filled box etc, the laser will halt and will keep emitting a low power beam. The console displays error code 3. I looked into some of the solutions to error code three but haven’t had any luck. I have attempted load the original Atomstack settings back to the board but I still have the same issue.

I’m fairly new to tinkering with the code but I believe it might have to do with the system not knowing the frame size and the relation to the laser, but now I’m lost. I have added some screen shots of the console readings along with my settings. Hopefully someone can spot where I am going wrong.

Processing: LIghtburn $.jpg…

Processing: LIghtburn $.jpg…

What GRBL firmware implementation did you use? Was it enabled with zeroing origin after homing?

The software version is GRBL VER 1.1h.20190830: OPT:VZ,1,128. I’m unsure whether it was enabled with zeroing origin after homing.
Processing: LIghtburn $.jpg…

Looks like you sent the reply before the image had a chance to complete uploading.

Where did you get this firmware?

I downloaded LaserGRBL V4.94 software and flashed it from tools option and Flash firmware.

I believe that should work correctly then.

I suspect the device is configured with the wrong profile.

Push Devices button in Laser window. Then click on the name of your laser and then Edit. Change the device type to “GRBL” specifically. Then complete the wizard.

Retest and report back.

Still no luck unfortunately. Here is the report I got from the console when I tried to run a circle.

Waiting for connection…
Grbl 1.1h [‘$’ for help]
[MSG:‘$H’|‘$X’ to unlock]
G-code locked out during alarm or jog state.
[MSG:Caution: Unlocked]
Target buffer size found
Starting stream
Layer layer1
Grbl ‘$’ system command was not recognized or supported.
On or near line 0:
Job halted
Stream completed in 0:00ok

Please provide the following:

  1. updated screenshot of Edit->Device Settings
  2. screenshot of Edit->Device Settings->Gcode tab
  3. run these commands in Console and return output here. Note that the first command will home the laser so be prepared for it:
  1. Go to File->Save gcode and save the gcode to a file with a .txt extension. Then upload that file here.

console settings.txt (1.2 KB)

For some reason the File > Save GCode option is grayed out. I’ve attempted to add a text file.

Remove the entry that’s currently in the g-code tab of Device Settings.

Then retest. What happens.

Do you have a design prepared and ready to burn? If not, that won’t be available.

Thank you very for your help sir! Removing the entry from the GCode fixed my issue.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.