Cannot get LightBurn to recognize laser

Hello,

I recently got a new laser, and I am having trouble getting lightburn to recognize it. I have a smaller laser just like it that works fine on lightburn. They are CH340 lasers that I bought off of Amazon. I run the smaller laser as a GRBL 1.1 or higher, and that’s what the big laser should run as too. When I plug it into the computer, I can see it showing under devices on the settings of the computer, so its not the USB cord. Also, I can make it work on Engraver Master. I tried to add the laser manually, and it recognizes that there is something plugged into COM5,but when you click through the settings (choosing GRBL, setting size, home. etc), it just says waiting for connection on the control panel. Any ideas that might help?

What’s the baud rate when you connect to it with Engraver Master is it something other than the LB default?

Thanks, changing the baud rate did make Lightburn recognize the laser, however now I have another issue. The laser will move, and come on however it is not burning. I focused the laser to the smallest point, but that didn’t work… Any ideas on this?

Again, thanks! I’ve been trying to get lightburn to at least recognize the laser for like 2 weeks now and you fixed it in a matter of minutes lol

$0=10 $1=254 $2=0 $3=0 $4=0 $5=0 $6=0 $10=1 $11=0.010 $12=0.002 $13=0 $20=0 $21=0 $22=0 $23=0 $24=25.000 $25=500.000 $26=250 $27=1.000 $30=10000 $31=0 $32=1 $100=100.000 $101=100.000 $102=800.000 $110=5000.000 $111=5000.000 $112=500.000 $120=500.000 $121=500.000 $122=200.000 $130=2000.000 $131=2000.000 $132=200.000

No need for thanks, I love sharing knowledge whenever I can.

Can you post a screen shot or 2 of the screens you get when you go to “Edit-Machine Settings” and the Edit-Device Settings windows in LB if possible would make it easier to follow along.

From a first glance $30 max spindle speed is set at 10000 in your controller I would do one of two things depending on if you only use LB or if you use other software.

If you leave the controller setting for now and just want to do a quick test then go to “edit-device settings” and change the “s-value max” setting to 10000.00 and you should have full power available.


Changing the spindle speed to 10000 did make it burn, however its a very light burn. I was burning at 100% power and 75mm/sec, and I was just burning the letter “B” so nothing too complicated.

Thanks again.

You might benefit from taking the time to read this. Home - LightBurn Software Documentation. It is the Official Documentation for LightBurn. :slight_smile: Click ^ that link.

We also have it available at the top of this forum.

Additionally, hover the mouse over most everything in LightBurn for a Tool-Tip, hit F1 for additional assistance, opening a browser tab, focused on the subject within the documentation.

In particular, Common Grbl Setups - LightBurn Software Documentation

Short version

  • You might need to adjust your spindle max RPM value ($30) to match the LightBurn default (1000) or vice versa. The value in LightBurn is called “S-Value Max”, in the Device Settings.
  • You might need to enable “Laser Mode” if you have GRBL 1.1f or later ($32=1)
  • If you have an older version of GRBL (prior to 1.1f) it’s highly recommended to upgrade the firmware, as Laser Mode also prevents the machine from pausing with every power change. The pause, which happens on older versions, or when not using Laser Mode, will cause excessive burn spots when engraving images.
  • If your machine uses negative workspace coordinates you’ll need to apply a workspace offset (G10 L2 P1 xx yy).
  • Set your machine status reporting to be relative to the workspace origin, not the machine origin ($10=0).
  • Make sure the controller is reporting positions in mm, as expected by LightBurn ($13=0)
  • If your machine does not have homing switches (also called limit switches) you will need to home it manually if you want to use Absolute Coords or User Origin modes
    .

Everything is good now, thanks for your help!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.