Can't configure gweike g2 150mm lens

Hello all, hope somebody can help.

I have a Gweike G2 fiber laser. I have just installed LB 1.7 Galvo and tried to set up the machine.

Lightburn detects the laser as BSL fiber (110 x 110). The laser has a 150 x 150 working area, not 110. When LB asks for the X & Y size, I have entered 150mm for both.

When setup is complete, I have imported the config file BslCAD.cfg from my GLaser software which works fine with the G2.

When I try and frame an object, the frame size is much bigger that the specified size. I tried lowering the laser head to 211mm focal point (which is the right length for the 110mm lens and the frame size looks correct. But when I go back to the 261mm focal length for the 150mm lens, the frame is way to big.

I’m guessing that despite me entering 150 as the X & Y size, LB is somehow still detecting the machine as 110 x 110 working area.

Is there something I can do to fix this?

Thanks in advance.

It sounds like the Red Dot scale settings are incorrect, or haven’t imported correctly from the BSL configuration file. You can manually adjust the Red Dot scale in the Device Settings window.

Since BSL support is still in beta, it may be helpful for us to see the configuration file you imported. Please email it to, along with a description of the issue you’re seeing.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.