Can't Connect Ethernet to USB C with Ruida

Please help! I am not the “tech” person in the household…he is in another time zone and unreachable at the moment.

Our Omtech was setup with a bridge? I am assuming through his laptop (which he took with him). I connected from mine (Surface Laptop, USB C ports only) via wifi in the past. Since he left I can’t connect to the laser.

I have tried everything I can think of. I connected directly to the laser with usb to usb c cord and it is not finding the laser. I overnighted an ethernet to usb c adapter and the controller is showing LAN on, but Lightburn is still not finding the laser or connecting when I set it up manually using the IP. I have downloaded the USB drivers from Ruida and installed RDWorks, which also can’t find the laser.

Can someone please tell me what I am missing? I am assuming there is a driver or a setting that needs changed, but I wasn’t involved in the setup and I am very short on time to try and learn everything I would need to know to figure this out. I would greatly appreciate any help or guidance in the right direction. I just need to cut one stupid piece to fix a mistake! I’m 4 hours in with nothing.

I’m running Windows 11 and I have the Surface Studio Laptop.

Thank you VERY much in advance! I’m desperate at this point!

If it’s literally only one piece and you’re in a time crunch consider saving the RD file to a USB flash drive, then plugging flash drive in to the controller and running it from there.

Wow. Yea. I didn’t think of that. Would I just set the laser up manually, to the specifications even though it’s not connected (so I can use Lightburn, I can’t import my settings, they are on a server I also can’t get to at the moment)? I have never used the USB feature before. Thank you!

Yes. The important parts will be device type, work area, and origin. The connection type you may want to set to one of the usb types so it doesn’t get stuck searching for the device.

I didn’t realize you didn’t have the device already configured in LightBurn as there could also be other configurations that may need to be done like for offset scanning (ie if the edges of an engraving do have staggered rows). This won’t be an issue if you’re only doing cuts.

In any case, using a flash drive or other you’ll still need to setup the device in LightBurn.

Also, is it possible that the job that you need is stored on the controller still? Not sure how you have been running files in the past. If you were using “Send” instead of “Start” then you’d likely have a collection of files on the controller.

@berainlb is a functional, quick solution. Unfortunately, we don’t know what ‘you’ know about what you are doing, the environment (personal or club laser) and what settings you may or may not need to change. The speed power is retained in the project file.

I have never tried to make a USB work simultaneously with Ethernet, if that’s what you are doing.

In the end, this isn’t a good long term. I think if you had it working on the network you should find out why is isn’t working on the network now. May be a more simple, faster and ‘cheaper’ fix.

Find out if it can be seen on the local network, I don’t know how to do that with a ‘lots’ computer/os, so you are on your own there. Probably google it… :crazy_face:

You should see the Ruida on the local network.

The Ruida controller will tell you if it’s connected, at least hardware wise… Mine indicates this on the right/bottom of the Ruida console.

I shouldn’t hurt to reboot the ‘bridge’, unless other users are connected.

You can check the Ruida IP configuration via Z/U → IP… I think…

Good luck


Good luck.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.