Cant Connect to CR10


(Dustin C Tanton) #1

'm trying out a tutorial of Lightburn for Gcode, but can’t get any commands to run on my CR10. I have seen people on youtube using their cr10 or ender3 printers but cant find any settings to make it work. My regular printing connection settings are COM2, 115200 Baud. when i open up lightburn, it says port opened, waiting for response. No commands go through.


(Rick James) #2

What firmware and version do you use to drive the CR10? What have you set up in the ‘Devices’ within LightBurn? These are important data points required to get things working properly.


(Oz) #3

Marlin devices need to be configured manually. When prompted by the automatic wizard, cancel out, then use the manual setup in the device manager to create a Marlin device. Because Marlin systems all run at different baud rates, it wasn’t possible to make the auto-finder work for it in a way that wouldn’t sometimes cause problems.


(Dustin C Tanton) #4

entering in M115 give me: “READ: FIRMWARE_NAME:Marlin 1.1.0”

In the Devices, i have it set up as follows:
Marlin
Serial/USB
Cr10
X axis: 360 Y axis: 360
Front Left Origin
image


(Oz) #5

I’ve only tested it with 1.1.9 and higher, but the connection itself should work.


(Dustin C Tanton) #6

this is what i get, you can see the console, nothing really happens, once i send any gcode to the printer, it becomes “Busy” in the bottom left, and nothing happens, cancel the job or anything, still busy…

are you saying you have a CR10?
Mine is a CR10 4S


(Oz) #7

I do not have a CR10, and have never used one. I have a generic Marlin board that I test with occasionally.

Try this:

  • Go to Help > Enable Debug logging
  • Right-click the Devices button to reset the connection
  • Try to send a rectangle as a line (cut)
  • Turn off the debug log again

Go to your Documents folder and look for LightBurnLog.txt - post that file here.


(Dustin C Tanton) #8

12:40:44.434 D: “LightBurn 0.9.04” “Fri Jul 12 2019”
12:41:04.151 D: DoAutoSave: “C:/Users/Printer/Downloads/3d Printing/lightburn gcode/milleniumfalcon_backup.lbrn”
12:41:14.572 D: Enumerating ports:
12:41:14.572 D: “starting” busy: false state: 0
12:41:14.572 D: Port: “COM2”
12:41:14.572 D: PID: 24577 VID: 1027
12:41:14.572 D: Manufacturer: “FTDI”
12:41:14.572 D: Description: “USB Serial Port”
12:41:14.572 D: System Loc: “\\.\COM2”
12:41:14.572 D: Serial: “AH06P8LBA”
12:41:14.572 D:
12:41:14.619 D: Found port: PID 24577 VID 1027
12:41:14.619 D: Manufacturer: “FTDI”
12:41:14.619 D: Product: “USB Serial Port”
12:41:14.619 D: Name: “COM2”
12:41:14.619 D: Port open succeeded
12:41:14.681 D: “starting” busy: false state: 0
12:41:14.681 D: “Attempting to connect” busy: false state: 1
12:41:14.681 D: “Connecting…” busy: false state: 1
12:41:14.713 D: O: “0a”


(Oz) #9

That says that it’s connected, sent a newline character to the controller to get it to respond, and it didn’t reply. Normally they respond with “ok”.

Do you see any other output in the console window after you connect for the first time?


(Dustin C Tanton) #10

itll say starting stream but nothing else… nothing happens.


(Oz) #11

It looks like your controller isn’t communicating back. Double check the baud rate to make sure that’s correct. Marlin usually sends a bunch of text when you first connect, so if that’s not showing up, the controller may not think you’re connected properly.


(Dustin C Tanton) #12

i have double checked the baud rate with my 3d printing software, same COM port, same Baudrate. I have even tried other baudrates just to roll the dice.