Can't control Sculpfun s30 Pro Max with Macbook Pro

I can’t get my new Sculpfun s30 Pro Max to respond to laser commands. The console recognizes my machine, but won’t move it. I’ve tried different Macbooks with different operating systems (Big Sur and Catalina). Yesterday, with an older machine I did get the laser to return home, but framing command just made the laser head move up and down and stop. Today, nothing from any machine. I’ve tried both USB to USB and USB to USB-C using adaptor. Any suggestions (getting a Windows machine?) are greatly appreciated. Thanks!

Did you install the CH340 chipset driver for the mac?

Install the driver on the Macbook you’d like to try.
Don’t fall for the pop-up OK window that backs you out of the installation.

Retest the connection. If it doesn’t connect right away Open the Laser window and click the middle button along the bottom row and select a different COM port. You should now see an option with the letters wch in the name. That’s the one you’re looking for.

Thanks John! Really appreciate your tips. Alas, more fails.

I’d try a Windows machine first, just to make sure it’s not a hardware problem.
Here is a step-by-step guide for setting up the laser (including instructions for Macs): Setting up the software - Diode Laser Wiki

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.