Cant find my chinese laser 60 watt

I have a 60 watt Chinese with a rudiha controller and lightburn will not find it during initial setup of software. please advise

What kind of Ruida controller are you using? How are you connecting it to your computer? What operating system is your computer using? What have you tried, and what were the outcomes?

I have tried connecting with a USB cable directly to the “PC” port on the laser. when I open lightburn and it ask if I want it to scan for device it doesn’t find my laser. I have the laser on and control board is on. tried with cooling and air on and off still nothing. I have a fairly new 64 bit thinkpad which is the software version I downloaded. here is the only info I know about the laser.

Brand: ## Preenex
PC Interface: USB 2.0 and USB Disk
Software: RDWorks V8, PowerCut, CorelDraw or AutoCAD
Image Form: HPGL, BMP, GIF, JPG, JPEG, DXF, DST, AI
Machine Dimension (L / W / H): 47.2" x 34.2" x 36.6"(1200 x 870 x 930 mm)
Package: Standard Wooden case for export
N.W.: 330.7 lbs (150 kg)
Maximum engraving depth: 3-4mm for acrylic, wood, 2-3mm for harder material
Maximum cutting depth: 5mm for acrylic, wood, 4mm for harder materials
Maximum engraving area: 700 * 500 mm
Warranty: 2 years warranty
UPC: ## 729270389690

When you plug in the laser to your USB, does it make the ‘ding’ sound, acknowledging you’ve connected a device?

yes it does. I also went in and chose rudiha controller manually and set up but laser does not move to software demands. the “set laser position button” does not move the axis

Did you install the FTDI drivers, at the end of the Lightburn install?

not sure. I downloaded the program the last week to start practicing. How can I check?

Reinstall the program, and make sure the checkbox is checked for it.

Uninstalled and reinstalled. Interesting that where I had manually loaded the controller it showed up after the download. I got it to move once with the move key but then it quit.

I appreciate your help here. Please don’t give up on me. I am heading out and will try again later this afternoon

Thanks

NP. Let us know how it goes.

The software quit, or it moved, and then stopped moving? Did you press the button again? Did it move again? We don’t charge by the word here, and being as descriptive as possible will help us help you.

got it working. thanks for the help!

2 Likes