Can't get CLOUDRAY rotary working

I am having a HELL of a time getting this darn thing working. I have all my settings correct or close (I THINK), the problem is when I send a job, I can see the cup just moving BACK AND FORTH and not rotating slowly, evenly in 1 direction. I have no clue why it does this or what setting would cause this.
This dumb thing ddint come with any instructions on how to use, I dont know if I use user origin, absolute coordinates, etc.
from what I saw, I am using user origin, middle left, and I put the design centered (to test).

Also I have no clue how to change the SPEED OF ROTATING, the cup goes flying off when it rotates to do the other side, I have no clue what setting to change to have it go smoothly. I tried the move tab:speed but it didnt do anything.

The setup for most of these are pretty simple. Since it ‘flies’ off the rotary, I will assume a ‘wheel’ type rotary, additionally that it’s connected to the Y axes. You did not specify and the setup is slightly different than a chuck type.

Ensure the steps/rotation is correct…

1.Check switches on motor driver board, note ‘on’ direction

  1. Find the matching ‘steps’ from the placard on the motor driver…

Mine is set to 2000 steps (pulse)/rotation (rev)

Apply the gearing ratio from the motor to the steps/rotation. Enter that in the Rotary setup in Lightburn.

Mine is 2000 (steps/rotation) * 2.5 (ratio) = 5000, that is entered in Lightburn.

rotary-controller-settings

The only other item is the ‘wheel’ or roller diameter. Mine was stated to be 63, but had to adjust as it wasn’t really, ended up at 62. If you have to make any adjustments, this is the place. Everything is digital up to the motor, this is where you fix the ‘analog’ part of the system.

Save your current configuration so you have a backup and then you can modify controller settings without worry of being able to recover. When you get it set up properly you can also save a ‘rotary’ configuration… that you can ‘load’ and ‘write’ to the controller when you want to use the rotary. After use, load and write the original configuration back and you’re back to the table.


The surface of the cup moves at the programmed speed. Centripetal forces eventually will pitch the cup off the machine. Slow it down… :slight_smile:

What’s happening is that the cup is not ‘held’ well enough to accelerate it at the controllers programmed rate. This causes an alignment issue with the artwork.


Mostly use an image or scan operation, if possible, moving the Y axes by the dpi, small increments and the X does most of the high speed work…

My Y acceleration values are commonly in the single digits. And you have to keep the Y axes speeds down because of the centripetal force.

Make sense?

Good luck… don’t forget the backup…

:smile_cat:

gear ratio

How do I figure out the gear ratio? or is it always 2.5?

The surface of the cup moves at the programmed speed. Centripetal forces eventually will pitch the cup off the machine. Slow it down… :slight_smile:

but HOW? that is what I am asking. How do I slow this speed down? Where is it? because it is not the regular speed setting that is at 400 movement. i tried changing it to 25 and it didnt change it

Also, overall, I dont know which motor driver board switches I am supposed to get my numbers from? I see 3 on my BOSS LS3655. The only one labeled is the last one, says Z DRIVER
if you are looking at the back of the machine, in order of left to right it goes:
4 and 6 on
4 and 6 on
2,5,7,8 on

so not sure which numbers to use

These are usually plugged into the Y axes. Whatever axes the rotary is plugged into, you want that motor driver. My Y axes goes to a bulkhead connector so it’s available inside the cabinet. I have to unplug the Y axes and plug the rotary into it.

You can compute the ‘ratio’ but I’d ask the manufacturer for it. If they sell this stuff they should know the ratio or be able to find it for you. In a nutshell it’s the ratio between the stepper pulley and whatever the ‘wheel’ pulley is. I’d ask the vendor or search on-line for it.

The ‘test’ button in the Lightburn rotary menu will rotate the motor one complete turn then return. You can mark the ‘wheel’ and ‘fiddle’ with the ratio looking for one complete rotation then back again. It’s much more simple to ask the vendor.

“Edit → Machine Settings → Vendor settings → Y axes”

Before adjusting anything here, make sure you make a backup as stated in reply 2.

Max acceleration, ‘jump off speed’ and ‘idle speed’ probably need modifying. Jump off speed is how fast it’s going to attempt to start the object rotating. I have all of these in single digits for the rotary.

It will take longer to get to speed, in the Y axes after this change.

You can also ‘tell’ it to run a max speed of whatever is set in ‘Max Speed’ this is the limit for that axes speed.

I would get on the horn to Cloudray and tell them what you have and ask about the ratio you need to use. I found a couple videos, but they all used chuck type cloudray and there is no ratio for those.

Not sure what you are referring? The switch numbers are at the top of the placard on the motor driver, first row. You will have to determine which axes and associated motor driver you are using.

Good luck - holler if you have issues…

:smile_cat: