Can't get Lightburn to connect to laser

We recently got a new computer, Windows 10, nothing special. I transferred our license to the new computer. We have an AWC708C PLUS controller on a Boss laser. And no matter what I try Lightburn won’t connect to the laser.

Find my laser option comes back blank, when I’ve tried to manually put in the information it won’t send a file and continues to say “File transfer failed”.

Any help would be much appreciated, I’m not sure what I’m doing wrong at this point.


Edit: Computer is connected via USB.

Install the LaserCAD software from Boss, and have it install the driver. That’s the part you’re likely missing.

I just tried both LaserCAD and LaserWorks v8, both installed a USB driver during the installation process, but Lightburn is still not recognizing any device being connected to the computer.

Any other ideas?

I also have confirmed that the USB cable works because I tried an old computer and it worked with connecting to the laser.

Does LaserCAD communicate with the laser on the new computer? My guess would be a driver issue or something in Windows 10 preventing you from talking to the laser. LaserWorks isn’t the correct software for that laser, so that won’t help, but seeing if LaserCAD can talk to it would tell me if it’s something that’s LightBurn specific or not.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.