Can't get Lightburn to connect to xTool D1 Pro

Lightburn does not recognize my xTool D1 Pro. Have installed the CH34xVCPDriver to no avail. The xTool Creative Space connected with no problem. Using a MacBook Air M1.
Any suggestions? Thanks in advance.

While I don’t have a mac, doublecheck your COM. Maybe cycle through them until it says ready.

have you tried importing the machine profile from the Xtool program files?
xTool-D1ProV3.lbdev (3.9 KB)

I’m not sure what you mean “importing the machine profile from the xTool program files”. I’m not very computer savvy. Please explain…and thanks for responding.

download this file and in the "new laser setup wizard window


hit the “import” button. then open the file you just downloaded. these are the saved setting that xtool has made for GBRL which is the language that your laser uses once it connected to lightburn.
Screen Shot 2023-04-26 at 11.01.16 PM
then lets make sure your machine origin is top left as shown here.

Please confirm that XCS is closed and not running in the background. If XCS is hanging on to the USB Port it can’t be found by another program or application.

I’m not certain that’s the same driver that I used but it may be worth a shot.

You may also need admin access to the computer to allow the driver installation to proceed.

The Driver is here:

Big friendly download button with a cloud and an arrow - Can’t miss it. :slight_smile:

The Mac offered me some friendly misdirection as an obstacle to getting the installation to completion.

When the mac offers to not install it, or offers you an OK to quit installing, please pick the second choice - the ‘Enter Password’ option or ‘install anyway’ option.

After the driver is in and working fine, you should see the letters WCH in one of the com port options. Select that port.

If the engraver doesn’t wake up right away, exit LightBurn and relaunch LightBurn. I would be interested to know if an xTool presents this quirk the same way my Comrgo Z1 did.

2 Likes

This worked like a champ! Thanks for the help! I appreciate it. I am now communicating with my new xTool D1 Pro. Thanks again.

1 Like

Which steps led up to it connecting?
Please let us know and click the solution button for the relevant post.