Cant get my co2 laser to engrave normally

Hello!
Just recently finished building my own co2 laser cutter. I am from a quite poor place, so I can’t afford these expensive ruida controllers, in fact, I wouldn’t want to spend more than 50 EUR on a controller. That’s why I am using Arduino mega with ramps and running grbl on it. I had a diode laser before, and it worked like a charm. But now with co2, I can’t understand really why it is engraving like this. (Check photo) I think it is something to do with the minimal power, which I can’t change because I am not running a DSP.

Photo

As you can see, the edges where the laser has to slow down, are shaded, but they should be sharp stopped. Is it fixable, is it just trial and error till I find the right speed and power? When using constant power mode, the edges are deeper instead of being lighter.

Try enabling overscan and see if that helps. CO2 lasers have a relatively non-linear power curve, and they have a point at the lower end where they cut off completely if the power value drops below their firing threshold. The number will be roughly 10% of your tube wattage - for example, a 40w tube will fire at around 4% power, while a 100w tube won’t fire until about 10% or so. Using overscan will keep the laser moving past the sides of the design, so the deceleration mostly happens after the engraving, and that should help.

Hello! That was the exact setting I was looking for. It fixed my problem, thanks a lot!