Cant see icon on Linux


I decided to try LB on my Linux system. It runs OK but the icons are not usable, can’t even see most of them. I tried various desktop styles and nothing helps.

I run Debian and KDE Plasma.

Of any of the styles you tried were any non-dark themes?
All of the icons I’m seeing in your screenshot look exactly as I would expect them to in the scenario that you changed the window style to a dark theme.
Unfortunately at this time we do not support such themes.
So, my main question is what does it look like with a more standard, light theme?

I tried all the themes including light ones. with the light themes, LB stays dark while other windows were light. I also tried ending and restarting LB between changes.

Oh wow - that’s definitely an important point. That was unclear before.
I’m honestly not sure - other than the fact that KDE is built on top of Qt, as is LightBurn… which makes this weirder, as you’d think it would work better on KDE than gnome.
Our main testing distros for Linux are Ubuntu and Fedora, both of which default to Gnome. That’s not trying to leave out KDE, it’s just that the vast majority of our linux users are using one of those distros and Gnome. Outside of the latest of those two distros your mileage may vary when it comes to Linux support. But we do our best to make it work on most linux.

That being said - what versions of Debian and KDE exactly are you running? I can try to replicate it here. My guess is that LightBurn is picking up some specific Qt theme setting that isn’t being used globally.

After a reboot, it seems to be working as expected. It would be nice if LB either changed the icon color on its own based on theme type, or allow the user to select color ( or at least gray scale from white to black ), put it right with the icon size slider.

For now I have found a working combination.


I’ll make a note in our tracker. This is honestly the first we’ve run into the issue.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.