Centre point of single straight line doesn't show when the line is selected in v0.9.09

I frequently use single straight lines as guides while drawing. It has always been easy to drag the line horizontally or vertically by clicking over the centre point of the line (used to be a grey square) and dragging.
Since updating to v0.9.09, the endpoints and centre are no longer present for a vertical or horizontal line, instead I get image . If I move the cursor anywhere on the line including the centre marker which shows as a crosshair circle, the line rotates. The only way I can get the original grey square centre marker is to move the line off vertical or horizontal. What am I doing wrong?
My setup is for a ruida controller, Win 10 PC.
The only thing I noticed when installing v0.9.09 was that it tried to install a visual C++ redistributable 14.11.xxxx, while the version I have on my PC is 14.14.26429, a later version. Other apps rely on this version, could this be the issue?
I really found being able to move the lines a s guides quickly and easily as in previous versions really helpful. Can you suggest anything to fix this issue?

I can confirm this “missing” gray handle in the middle of a line in my .9.0.9 ver downloaded last night.
Now my failing memory doesn’t tell me if that middle line handle was there a version or 2 back!

I have the same behaviour in 9.09 and I didn’t see the C++ message. So might be something Oz has changed. I have 9.07 at home I can try it later unless Oz gets here first…

I am pretty sure it was OK in v9.07, I have been using it up until I upgraded to 9.09, I was too late for 9.08, 9.09 had already been released.

This is found and fixed. It’s because of some math done to shift the drag points away from the shape, to allow you to grab corner snap points. When the object has no size in one direction it confused the code. I’ve changed the math to account for the zero size possibility and we’ll have this out shortly. I’m going to wait a little bit to see if anything else pops up.

We’re changing how we handle releases in the future. This one was too messy and some things didn’t get enough time in test because of the Boss deal release date, but that’s not an excuse. This should’ve been done better.


Wow that was quick. I look forward to the update, in the meantime my workaround is to use a thin box as a guide. Hope this helps others. I do like this release overall especially corner fillets.
Thanks for a great program.

I didn’t realize how much I relied on this until it was gone. Any idea on availability for the fix? Thanks.

I can likely do this tonight. I wanted to wait to see if anything else crept in, but I think we’re good.

Just installed the update, and tried it out. I now have the end and centre points for a single line, this functionality has been restored, Thanks Oz.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.