Changing speed causes size to change and no laser output

I have a k40 type laser with Arduino uno and cnc shield running GRBL 1.1h.
Got everything setup and all seems to work. X and Y moves. Laser fires.
But
If I change the speed in LB the size of workpiece changes size and laser does not fire anymore.
Any idea what to change or where to look for this funny fault. Thanks

Highly doubt it’s a Lightburn issue. More likely how you have your Arduino/grbl configured incorrectly.

Lightburn only sends the standard grbl controls and that doesn’t change Lightburn ‘size’ of the device.


Have you tried to issue console command to change speeds and power.?

Good luck

:smile_cat:

This deserves some additional explanation. What are you referring to with workpiece? Where are you saying the size is changing?

At what point is the laser not firing?

Some elaboration on context and conditions for what you’re experiencing will be important to understand the problem scenario as well as potential fixes.

When I make a square of say 30 x 30 mm…that I call my workpiece. Now in LB I make that vector say RED.
I do the cut and everything moves and works OK. Now I want to change the feed setting for this RED vector. I leave the power setting as is but change the SPEED to cut quicker for this red vector. Now my machine moves the same speed but it moves 70 mm x 70 mm and not the 30 mm x 30 mm and the laser does not fire.
I really cannot describe it any clearer unfortunately

You’re saying the dimensions of the laser motion doesn’t match the design dimensions?

Lots of questions:

  1. Are you saying this only occurs during a change of a speed? I’m curious how the dimensions would be correct the first time.
  2. If you create a new object at the revised speed does it burn appropriately?
  3. Does this only occur at certain speeds?
  4. Is this accompanied by any message in Console?

In order to make this more systematic I suggest you run some tests:

  1. Make 3 squares at 10x10 mm, 50x50 mm, and 100x100 mm or something comparable
  2. Duplicate the 3 squares into 3 separate layers
  3. Set the 3 layers at different speeds
  4. Run the job
  5. Measure the burned results and make note of variance from design

Yes by changing the speed it looks like it changes the steps/mm.

Has this worked in the past or has something been upgraded?

:smile_cat:

As stated in my first post. Old K40 laser upgraded to Arduino Uno with cnc shield and GRBL 1.1H
Therefore a new setup. Still trying to get all the bits to work together

I would check how your grbl controller is configured. There is other grbl freeware out there you could also test it on, but if it’s new it’s more than likely a controller configuration issue.

I don’t think grbl will execute changes in the ‘registers’ when it’s executing a job. So that really leaves out any ‘driving’ software…

Good luck

:smile_cat:

Yes I believe it is a setup issue. But I don’t know where to look. If I could find somebody with the same setup ie. ARDUINO Uno. Cnc V3 shield and GRBL 1.1h so that I could compare setups

I’d go look for a ‘how to’ configure for that version of grbl. When I was using grbl, most of the options were ‘compile’ time.

That would be the best starting place.

:smile_cat: