Cheap Chinese Laser

Hey guys,

New to this laser stuff. Just bought a cheap Chinese laser from eBay, the seller was a re-seller and doesn’t actually know anything about them, so, here I am, a newbie trying to set it up.

Managed to eventually assemble it as I was trying to go by the photos on the eBay listing but they were wrong. Anyway, it’s all assembled and I’m ready to go. Downloaded the trial of LightBurn but it doesn’t recognize the laser, I simply can’t connect to it. Tried other cheaper and free software but the same issue.

What do I need to do to be able to connect to it and get it to run?

Yours sincerely,

Frustrated Newbie.

What is “this laser”? Do you have literally any info for us to work off of?

Only what you see in the photos. Came with no instructions at all. This is a similar eBay listing:

Yeah, and that’s a very informative listing.

If it connects to the computer over USB cable, and there is no mention of a wifi connection or a memory card/ screen for computer-less operation, then this gives us hope. Hopefully the machine runs GRBL firmware and will be able to talk to LightBurn.

It is a STM32 chip on your controller board, which makes it weirder to deal with. I don’t know what board specifically that is or what flavor of GRBL would work for specifically that board or chipset.

Does your computer ding or show anything when you plug in the USB?

Yeah, it makes a ‘Da Bi Ding’ when I plug it in and unplug it. Under the computers devices list it recognizes it as “USB-SERIAL CH340 (COM6)” the COM6 will be the port it’s plugged into, have tried the other ports with the same result, but nothing else can see it and can’t find it under printers.

Try to manually create a device that is GRBL and select port COM6.

Follow these instructions:

See if anything happens. Be very descriptive about what does and does not happen when you reply back.

Ok, I’m not the greatest at these things but seems all pretty straight forward. Did as you suggested, Lightburn says ‘Ready’ where as I was only getting ‘Disconnected’ before. But whenever I try to do anything nothing happens (ie moving the position, pressing start etc) and Lightburn just crashes.

Do you see anything in the console at all when you connect to it and choose a COM port? If you connect a GRBL device at the proper baud rate, you’ll see the standard “Grbl 1.1f [’$’ for help]” message. If you don’t see anything, or you see random garbage, you either have the incorrect baud rate, or the board isn’t using normal firmware.

All that comes up in the console is “Waiting for connection” even though below under laser it says connected.

That line under it that says ‘Ready’ means that the PORT is opened, but the console is the thing that’s important - If you don’t see anything in the console, it means the laser isn’t communicating with LightBurn.

You could try going to Edit > Device Settings and choosing a different baud rate. Some older GRBL systems default to 9600 baud instead of 115200. If that doesn’t work, then I would try to locate the original software for the machine and see if you can get any information from that.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.