Check for Updates "network error"

Well, I downloaded the 0.9.06 appimage and ran it. Lighburn opens and runs fine. But if I click" Help > Check for Updates", I get a network error message. I’m not sure if this error is new for the latest version or if it existed in 0.9.04 also. I don’t think I ever clicked it in 0.9.04.

Also, I assume there is supposed to be a splash screen of some sort that displays for a few seconds when LB is started. I remember there being something when I used win7.

But since I’ve been a Linux Mint user (currently 19.2) I have never seen this screen. What I do see is a narrow outline of something that appears for a few seconds just before LB opens. The outline is there but the contents are invisible. You can see it (barely) in the screenshot below. Didn’t work for me in 09.04 either. Neither item is a big deal, but I thought I’d mention.

We’ve tested on Ubuntu (built on 16.04, tested on 18.04 as well), Fedora, and a couple of others. Not sure about Mint. Unfortunately, Linux seems to be more of a “standard” than a standard. The SSL context error is because of a weird version interaction with libssl and some other library (I can’t recall which). This might shed some light:

The update check is handy, but you can always download from the Trial / Download page on our website - It will always list the latest version there.

@adammhaile - Did you test the AppImage on Mint? If so, which one?

@LightBurn @Hank - I tried it on on Mint 19 with the result of “Unsupported” because we require Kernel 4.15 or higher and the latest kernel on 19 was too old. The version @Hank is using, 19.2, was just release 2 weeks ago… after I completed the AppImage stuff. In theory, it should work as it’s running kernel 4.15 now, but it would seem it’s doing something weird with libssl compared to other distros.

I should have some time tomorrow to get a Mint 19.2 VM setup and test it there. Hopefully it’s just a small thing to fix. @LightBurn - the real problem here would be that if the update check fails, the license code validation will fail too. Since he’s already got it validated, I assume, it’s not a problem. But could be an issue for others.

I’m not too worried about the update check at this point. Like Oz says, I know where to go to look for latest. As long as it doesn’t cause any future license issues.

If there’s any other info you’d like, or anything I can do at this end to help troubleshoot, just let me know.

So, I’ve confirmed it’s only an issue with “Check for Updates” and only on Linux Mint (at least among my test systems). Sadly, despite using a newer kernel finally, Mint 19.2 still uses an old libssl that’s incompatible.

OK, thanks for looking in to it Adam. I can live with it.

Adam, wouldn’t manually updating the libssl fix the issue?

Depends on what else in the system uses it. If LibSSL is used by other things on the machine, expecting the older lib, updating it would fix LightBurn and break everything else.

What kinds of “things” might it break? Is it just a single file that I can rename and try the new one, and if stuff breaks go back to old? Or is it more complicated than that… ?

All https-based browsing, for a start. :slight_smile:

Adam would be a better person to ask about whether it could be painlessly updated or not, but I suspect it’s not quite so simple.

I get the same error on Elementary OS which is Ubuntu 18.04 under the hood. This happens with 0.9.04 and .06.

You can’t bundle and use your own isolated version of libssl?

We’re looking into whether that’s doable or could cause other problems.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.