Chuck Rotary Need Help

Not sure if I need to ask here or somewhere else, but any suggestions would be appreciated. I have a 80W OMTech Ruida RDC6442G and I cannot seem to get the rotary to rotate on “y” axis. I have watched all videos on installation and followed instructions on this site for setup and its still not recognizing “y” axis. It’s plugged in correctly & rotary setup is enabled in Lightburn. Am I missing something? Not sure if I have a bad connection or software issue. Everything else works.

So…when you try and jog the Y axis directly from the Ruida control panel…does it rotate. If not I would suspect strongly its in the rotary and probably either miswired…or maybe one of the wires broke off at the connector etc. I mean if the Y axis works fine on the laser when the rotary is not in etc but once the rotary is installed and you can’t even jog it off the panel then the issues is in the rotary. Not like OM sends top shelf rotary anyway…I have one and it works but they are cheap.
So…does it jog from the ruida panel…yes…no…

There are also two phase and three phase rotary setups and depends on your laser and I think OM is two phase…simply put depends its the wiring setup coming into the connector on the laser side from the controller…possible you have the wrong one …ie…you have a three phase stepper when you need a two phase or vice versa. Won’t be software especially if it won’t rotate from the panel of the Ruida.
Did you buy the rotary seperately since its a chuck style…if so you may have the wrong wiring.
I have a 60 watt OM tech as well as a 50 watt…they are wired the same. If you want take the connector apart on the rotary. Loosen the two small screws that clamp down on the wire and then either unscrew the connector back from the front if it is that style or they may be a small screw on the side that keeps the connector togther.
There should be 4 wires…assuming they all use the same color code…mine ispin1 red pin 2 blue…pin3 black and pin 4 green. numbers are easier to see on the front of the connector.

Make a schematic of how you did the wiring so we can better guide you

Yes “Y” axis works fine on laser when rotary not plugged in. I cannot jog off the panel.
Here is a pic of the wires I have. blue, green,yellow & red.

This is looking at plug from the end.

Well if the y axis works fine when rotary isn’t plugged in and you can move the y axis from the panel when it is in its normal setup then…it’s an issue in the rotary. Laser doesn’t “know” wether there a rotary or not right…it’s just a stepper motor is all. So it will make a stepper move if it’s wired correctly and it’s the proper motor irregardless of what it moves. Even lightburn would make the rotary jog without enabling rotary….all that does is tell lb to use the calculations you set in the rotary setup so that it rotates the part correctly. But even with rotary set off it will move it cause again it’s just a stepper motor like the one in the y axis gantry.
Now you might want to reply with the pin out…which color wires go to which pins…I find it’s easier to look at the front of the plug.
Did you buy this rotary separate from the laser or did it come with it. Also was it prewired or did you solder the connector up.

If you have a multi meter you can check continuity between pins 1and 2… you should have continuity…the same for 3 and 4. 3 and 4 are A+ and A- which are field windings in the motor as are 1and 2 which is B+ and B-…. There should not be any continuity between 1,2to the 3,4 side . This assumes the Y plug on the machine is pinned the same as the stepper driver so you might have to look at the back of the Y plug on your laser. I would assume the rotary plug is wired incorrectly for the machine y plug

I bought the rotary & laser at the same time both from OMTech. Rotary came prewired. Here is a drawing of plug looking at front end. And thank you for taking the time to answer and help me out!

if you have a multimeter and can check continuity you can do this and you need a meter to troubleshoot this.
I assume you are unplugging the Y axis connector in the back and plugging in the rotary into this correct. I ask as that is mine and it is an OM but you have a bigger laser…but I assume OM uses the same setup.
So if you do it this way…take the Y axis connector you unplugged (that goes to the Y axis gantry) and check continuity between each pin…write down which ones have continuity to each other. I assume it should be 1,2 common to each other and 3,4 common to each other as these are the motor windings.
Then check your rotary…they must match. As I said one set is windings B+ and B- and ones A+ and A- which one goes to which pins should not make a difference in it working although it may run backwards. But if your rotary does not match up it won’t work,
this is the only way to check really…using a multimeter…unfortunately different rotary makers use different colored wire so you cant trust by what I have verses you and as you can see I do not have the same color coded wires.
Let us know what you find

Hi,
I have also an issue with my rotary (simpel roller).
I have a 60W (chinese) co2 laser with a Ruida 6445G controller.
I plugged it in correctly en I can rotate it by software and the control panel by hand (incorrect direction). But it doesn’t react to the adjustment on steps per rotation and it doesn’t start automatically to burn a test file. I also cannot inverse the direction.
Please help?!

Update!
I have solved the direction issue. the wiring was incorrect. I still have problems with adjusting steps per rotation and it doesn’t start to execute a file!

This is worth review: Rotary Setup - LightBurn Software Documentation

The Ruida 6445 is a little different to the previous Ruidas with regard to the rotary. You don’t disconnect the Y axis and plug in the rotary there. The rotary requires it’s own stepper driver that is connected to the U axis on the Ruida control box. Another difference is that you cannot use the start button in Lightburn. You have to Send the file to the memory in the Ruida and then run the file from the Ruida console. It took me a while to get mine working because of this.

Great.
thank you for your reply. I will try this.

I’ve tested it and it works!
Thanks again.