Circle width/height not making circle when set the same problem

Hi, using LB V 0.9.24

Problem:
When trying to cut a circle it turns out oval - even with the width and height set the same. The measurements show correct on the monitor, and the circle that shows in the cut area is perfect looking - but the actual output is slightly oval.

The X axis is correct/true to the measurement - but the Y axis outputs about 3mm+/- narrower, thus making the slight oval. Both Lasers with different boards output the same result leading me to think it is something with Lightburn software…

These both output same result: A) Gen5 with LaserBoard and B) K40 with Cohesion 3D Mini board. Both use smoothie.

Any thoughts?

ETA: That when creating the circle that I tried to cut - I drew it first with the circle tool in the left hand sidebar and then set the exact height/width both manually, and also with the lock on. Once when I input the width and hit enter the height didn’t change even with the lock on, but most of the time it worked. I was testing different circle sizes to see if I could get a true circle… but the issue was the same, just the circle sizes changed.

Did more tests today.

Made a circle with two other programs and saved as svg. When imported into lightroom with no further adjustments - just straight to cut - same issue!

In order to actually cut a circle that was 74mm in diameter I had to set the width to 74mm and adjust the height to 78.5mm.

Cutting a square with the square shape on the left sidebar worked fine.

@LightBurn can you please advise about this. Thank you

I see they are similar, but far from the same…

Do they work properly with other laser software?

The reason I’m asking is that the things that usually cause this is belt tension, binding or some kind of mechanical issue, if they have been working before. The configuration of the stepper motors are not modified by lightburn that I know of or could imagine them doing that without you initiating it.

Do you use the ‘preview’ window to see how the machine will move?

I don’t know much about smoothie either, but is it their firmware on your controllers?

Good luck, now I’m interested… :slight_smile:

Hi Jack, thank you for the reply.

I am fairly certain it is in the software?

Why, because:

I used two completely different lasers with completely different boards and motors and etc. Same result on two completely different lasers. Only thing the same is the software used. Lasers: A) Gen5 with LaserBoard and B) K40 with Cohesion 3D Mini board. Both use smoothie. Both have different steppers, belts and so forth…

As far as making circle in the past: I can’t remember if I just made any circles. Usually I import images and then offset shape when cutting outlines. Have not done much since the upgrade to the current version, so hopefully this is the only anomaly encounter.

However, prior to the most current version, I think I had 9.19 - which if I did cut circles, worked fine before.

Hopefully, @LightBurn may have an idea? Thanks, Em

ETA:

Two more troubleshooting tests:

Using Lightburn to jog/move ten steps to X and then ten steps to Y, they both measured the same. No anomaly there. Making it even more confusing why the discrepancy making a circle. Width and Height of circle the same but for some reason the output is not, even though the software screen shows a perfect circle.

Q: What part of the code (or smoothie talking to the software) translates the Y measurements between the circle on the screen/program and the actual output? Perhaps that would help drill down on what is causing it? Because when I added 4.5mm to the Y axis for a desired 74mm circle, it then output a circle. I had to input width 74mm and height 78.5mm to get a circle to cut out. In smaller circle tests it was closer to a 3+/- discrepancy on the Y.

So if you draw a 75mm circle inside a 75mm square and run it, what do you get? Can show result please?

image

I suspect you may have acceleration set too high on the y axis and the system can’t keep up. This wouldn’t affect a square as much as the y movement is constant.

@Lignumaqua

Good thing to check. Sorry for my ignorance with this Q:

Would this be a smoothie card issue/setting. Asking because I get the same result on both of the different lasers that use different cards that came with the board when purchased from Cohesion. One is Laserboard and one is C3D Mini. Should I copy the files from each card and post here?

Or is that a setting in the Lightburn software somewhere? And if so, where do I look for that setting?

Side note: A square does not cut out perfectly either. I just realized this today when performing the test Hank asked for.

@Hank I did a few videos on the subject. There are several issues I have encountered. While there could be others, this is what I have come across (using v 9.24):

A) when inputting 75mm into the width box with the lock on it will not change the height as it is suppose to. Same thing if I do height first - will not change the width. Have to input it manually to get them the same.

B) Putting a circle in the square still didn’t output a perfect circle. Also, it will not output a perfect square either - even though on the screen they look correct to my eye. I just found out about the square not cutting true either, since I didn’t try a square the other day.

Issue A) is not computer specific since I have Lightburn on two different computers (both do have windows 10) and this happens with both. Only one computer is hooked up to my two lasers.

Thank you both for helping and ideas, Em

Videos: please forgive to the horrible quality…

Main video (Gen5 with Laserboard and smoothie) showing the two issues I am currently having and output results: Gfen - YouTube

Supporting videos:

K40 (C3D mini board with the smoothie software that came with the board) cutting circle from within a square - still didn’t get a true circle with this laser either: K - YouTube

Second computer with Lightburn installed (desktop) - same issue with the width/height when lock is on. Will not change the other box and can only get the same by manual input: Not hooked to the Lasers. Lightburn Width/Height not working with lock on? - YouTube

Shows that a square also does not cut out true even when the width and height are set the same in the software: Sq - YouTube

Hi I posted video links in Mike’s reply:-)

You’re misunderstanding how the lock works.
The lock constrains the proportions so that if you change one dimension the other changes by the same percentage. If you want to change only one dimension, or both of them independently, then you need to turn the lock off.

As for the Y dimension discrepancy, lets start with: You don’t have rotary enabled do you?

image

PS, even when doing a circle in a frame where the square shows as T1 mode = tool and speed/power = frame with the circle in the frame (different color) it still cuts out not correct - same as results in video. I didn’t show it this way in the video and just tried it with the “tool” in the cuts/layers panel getting same result.

OMFG, LOL! Yes, I had rotary enabled. I last used Y for my Y axis rotary and forgot all about that. Just tested and now getting a “circle”. Yeah…

It’s the simple things that bite:-) THANK YOU!!!

I love a story with a happy ending. :smiley:

2 Likes

Most of these programs generate the code to do what’s required. When you run preview, it just executes the code that it will send to the laser with a virtual ‘laser’. There’s generally no translation as there is nothing to translate. That’s what make them effective tools.

Whenever you have weird issues look at the configuration, as you now know. I’m in my 60’s when I change something that I need to change back, I put a ‘post-it’ note on my tube, too forgetful.

Take care, have fun :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.